CCA installation with new 8.0 pkg

Unanswered Question
Jan 25th, 2010

I am hoping to receive feed back from our Cisco SBCS support team in regards to this question if possible?

I have attempted to upgrade the office demo UC520 with versions 7.1.3 and 8.0 but in both cases the full upgrade starts then aborts stating this is not a valid package.

I have tried to unpack,minimize and repack the bundle as per some partners suggestions in these discussions. I have verifed the version of CCA and CUE are current. I have removed all extraneous localization, phone and wav files to be sure I have maximum space but in the end had to revert to the CLI to upgrade discreet portions of the package.

Is it possible for Cisco to identify a minimum starting point you need to have to be successful with a pkg upgrade via CCA (or CLI for that matter)?  It would ideal if the list identifed minimum hardware (IE: RAM & DRAM requirements), CCA, CUE and IOS versions and base flash files to start with.

I apologize if this has been identifed prior but I have searched this discussion and global cisco.com with no success.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Tue, 01/26/2010 - 08:22

Hi Paul,


We have an outstanding issue with the upgrades and the flash on the box. Can you please open a TAC case? TAC can help you with this.


Thanks,

Marcos

paul.sheehan Tue, 01/26/2010 - 15:41

HI Marcos;

I appreciate the info but we dont have a smartnet on the demo unit.Do you have any other suggestions which may help here?

regards,

Paul

John Platts Tue, 01/26/2010 - 09:33

I want to be sure that you can unzip the UC520-8.0.0.zip and the SCUE-UC520-7.1.3.zip files without any problems.

In addition, please do the following before you perform a UC520 upgrade in CCA:

  1. Under the Troubleshoot section in CCA, select CUE Exec Commands.
  2. Be sure that your UC520 device is selected in the CUE Exec Commands window.
  3. In the CUE Exec Commands window, type wr mem in the Command: box, and then press the Execute button. Wait for the wr mem command to complete.
  4. Switch to the Topology view.
  5. In the Topology view, right-click on your UC520 unit, and then select Restart CUE. It takes about 10-15 minutes for CUE to come back up, and be sure that the CUE restart has completed before proceeding to the next step.
  6. Do a backup of your UC520 configuration by using the Configuration Archive.

The above steps ensure that the CUE configuration is saved, the CUE module is restarted, and the UC520 configuration is backed up before the upgrade is performed. Restarting the CUE module before doing the upgrade appears to make the CUE upgrade successful.

paul.sheehan Tue, 01/26/2010 - 15:42

Hi John;

Thanks for your advice. However, I can install a new CUE via CLI just not the pkg from CCA.

regards,

Paul

CHRIS YEO Sat, 02/06/2010 - 22:17

Guys,

I have the solution for this... after some trial and error tonight.

The answer is that (and this includes CCA 2.2.1), if the phone load is bigger than the flash available it quits with a generic error about the tftp server.

So I pruned out the phone loads to only use the ones that we have, as well as the 500 series, and the upgrade went 100%.

Now for the Cisco team, you should report back to the the devel team to let them know that they should do a better job extracting only the phones requested instead of all the phones.

If anyone needs help with this, I can assist.

Thanks!

Chris

Steven Smith Mon, 02/08/2010 - 09:24

Hi Chris,

You did this be deleting the firmware off of flash, or by selecting fewer phone loads to upgrade with?

CHRIS YEO Mon, 02/08/2010 - 13:56

Steve,

What I ended up doing was this:

Unzipped the UC520xxx.zip file.

Using 7zip, opened up the tar file for the phones

deleted a bunch of the directories so that I was using a much smaller amount of phones, specifically leaving, the 5xx series, the 794x/796x, the 792x and the 7970.

Recreated the UC520xxx.zip file and uploaded via the cca.

When I did select only the phones that I wanted, it still failed to upgrade, and when I left the 7975 phone in there it failed to install the support files, but the rest worked.

So I would have to say the process of selecting the phones still attempts to unarchive the entire file or thinks it's going to.

I can upload the exact file I used for my 520 if you want to see it.

Thanks!


Chris

jmbonsack Fri, 02/19/2010 - 09:09

Is this still coming out today?  I really need it; all my ephones have types configured but I still can't get past the blank PLM software upgrade screen.  Tried removing phone entries in the tar file buried within the zip file, but CCA barfed on an incompatible file immediately.

Thanks for any update!

-mark

jmbonsack Mon, 03/01/2010 - 09:55

I downloaded the new 2.2.2 package, but I still get a blank "select phone loads to upload" page from the PLM.  What else could be wrong?

Steven DiStefano Mon, 02/08/2010 - 12:51

There was an issue found in CCA 2.2.1 where PLM would NOT launch during SW  upgrade, CSCte30084 (internal BUG)

If PLM launches, then it would prevent upgrade from  proceeding if phoneloads selected exceeds available flash.This is true for UC520, not the UC540 which has room for all of them.

Fix for CSCte30084 is  included in CCA 2.2.2, which is currently in beta.

Please work with SBSC offline if would be willing to sign a beta agreement to be given download  access for the CCA 2.2.2 beta version.

Or check your configuration to see that every EPHONE has a TYPE (the model of the phone).   If the config doesnt have this, it may cause the whole problem....

Steve

Actions

This Discussion