DHCP not passing through?

Unanswered Question
Jan 25th, 2010

I have a Cisco Aironet 1130AG Wireless Access Point which I am having some difficulty in setting up.

The network is basically a small Workgroup with a Cisco router to connect to the internet and a Mitel 3300 Cxi phone switch which does DHCP. There are no servers.

All PC's can pick up and IP address and get internet connection when cabled in, but if connecting wirelessly then they do not get an IP address. The Aironet is configured with a static IP address. If I try to get it to pick one up by DHCP it does not get one. If I give the PC's static IP's then I can connect through the Aironet.

I have tried the Aironet on my own site with a server handling DHCP and it works via the Aironet straight out of the box passing through DHCP requests.

Any ideas as to what is going on here?

Many thanks

Dave

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
davesydenham Wed, 01/27/2010 - 00:39

Hi,

The DHCP comes from the phone switch. I am just trying to pass the DHCP through the Aironet. I have not set anything up within the Aironet for DHCP.

If I set the Aironet to pick up an IP address itself from DHCP this does not work.

When I connect the Aironet via another network (Domain with DHCP running on a 2003 server) then everything works as you'd expect.

So I'm not sure why it does not work with thr phone switch doing DHCP.

Thanks

Dave

sitkom@usa.net Wed, 01/27/2010 - 06:30

Typically this is an issue with Windows networking setup, not the access point.

When you configure the internet settings (TCP/IP), and select ,  select "Obtain IP Address Automatically" and select at the bottom of the window.  In the window, add the IP address of the DHCP server as the 'Gateway'.  Only do this if the gateway is, in fact, the DHCP server, which it should be if your network is configured properly.  9 Times out of 10 this will clear up DHCP pass issues with the APs.

Hopefully that helps.

davesydenham Mon, 02/01/2010 - 02:39

DHCP is not being done on a server but by a Mitel Phone switch via an HP ProCurve switch. Any PC plugged into the HP switch will obtain an IP address from the Mitel system. The Cisco will not. When I plug it into my own network where DHCP is handled by a Widows 2003 server then the Cisco will pick up and IP address and pass through DHCP to the clients.

Is there any issues with compatibility with DHCP from a phone switch like this as it is the only thing I can think of? I have tried all combinations of connections and this is the only combination which does not work.

Thanks

Dave

nickml007 Mon, 02/01/2010 - 10:51

A couple stupid questions:

Are you using the right ethernet cable? (x-over or straight-through)

Have your tried a write erase / reload ? (making sure you back up your config first).

davesydenham Tue, 02/02/2010 - 00:54

Yep, have tried a couple of different cables (and proved the cables also) to eliminate this possibility.

I'm not sure what erase / reload is, but assuming you mean resetting the configuration on the device I have not tried that as it works on other networks fine. I'm sure the device is not at fault but looks like it cannot deal with the phone switch DHCP for some reason.

My next step is to try a different (non-cisco) device on this network to see if it will work.

Thanks

Dave

George Stefanick Tue, 02/02/2010 - 20:15

So are you on one flat network ? Or is the phones and wireless on different subetnets... if they are different is the hepler configured?

davesydenham Wed, 02/03/2010 - 08:19

No, all one subnet. In theory as simple as you can get.

I have now resolved the situation by installing a Huawei wireless router to do the same thing. 10 minutes to configure and it just works.

The Cisco works everywhere else other than this site so I can only conclude it is being 'fussy'.

Would love to understand why it doesn't like this setup if anyone can shed any light on it.

I have had a similar issue in the past with a Cisco ADSL router which dropped connection due to a degradation of the copper line. Someone suggested trying a cheapo ADSL modem and sure enough it would support the connection where the Cisco wouldn't. Anything in this do you think? Are Cisco's more fussy?

Thanks

Dave

George Stefanick Wed, 02/03/2010 - 08:44

Dave,

Sniff the port and see if you see the dhcp request and ack... This would be a start ,,,

Actions

Login or Register to take actions

This Discussion

Posted January 25, 2010 at 8:00 AM
Stats:
Replies:9 Avg. Rating:
Views:2578 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard