RVS4000; IPSec; VPN; Shrew Soft IPSEC Client

Unanswered Question
Jan 25th, 2010

Has anyone had success in connecting from a single remote workstation to an RVS4000 using NAT?  Second, has anyone had success using the VPN Client from Shrew Soft available from shrew.net?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Iwan Krastew Wed, 09/14/2011 - 09:44

Hello Michael,

I know the thread is old but I could not find the information requested in our forum. Here is a link to the recently uploaded document on how to set up VPN tunnel using Shrew Soft VPN to RVS4000:

https://supportforums.cisco.com/docs/DOC-18443

I hope this will be helpful for everyone!

Best regards,
Iwan Krastew

coreykasten Fri, 12/30/2011 - 06:13

Iwan,

Thank you so much for making this helpful setup document. I have been able to connect to my work VPN using your tutorial on Windows Shrew VPN. When I tried it on Linux (with ike version 2.1.7 on Ubuntu 11), however, it failed to connect.

On linux, the message I got from the GUI when trying to connect is:

...

gateway not responding

tunnel disabled

detached from key daemon ...

Do you know why it would fail?

One thing I noticed is that the options for "Phase 2 -> Transform Algorithm" do not include "esp-3des" (or anything with "esp" in the name).  Instead I chose "3des". Do you think this is the issue? Is there a way to make this work on Linux?

Thanks

Corey

Iwan Krastew Fri, 12/30/2011 - 08:42

Hello Corey,

"esp-3des" is only an option in the Shrew VPN Client. This option is called 3DES in our router. However, this should not be the reason why it is failing to establish the tunnel. Can you please make sure that you are not using any firewall rules that might prevent the connection (i.e. iptables).

You can check it using the following commands when you are logged in as a superuser (root):

# iptables -L

# iptables -L -t nat

Reset them using:

# iptables -F

# iptables -X

Please report if you have found out what might be the reason. I will try to create a tunnel using Linux environment early next year.

Best regards,

Iwan

coreykasten Wed, 02/29/2012 - 12:15

Iwan,

Have you had a chance to try to get RVS4000 VPN working with Linux via Shrew VPN?

Thanks

Corey

Actions

This Discussion