Problem uploading new software to ASA

Unanswered Question

This is what happens when i try to load new software to the ASA.  

FW-1# copy tftp disk0

Address or name of remote host [x.x.x.x]?

Source filename [asa822-k8.bin]?

Destination filename [disk0]?

Accessing tftp://x.x.x.x/asa822-k8.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

%Error writing disk0:/disk0 (Cannot allocate memory)

Now there is space on the ASA...

Directory of disk0:/

12     drwx  8192        11:37:40 Nov 10 2007  crypto_archive

111    -rwx  11491880    11:00:36 Dec 03 2009  asdm-623.bin

113    -rwx  16275456    15:25:30 Dec 07 2009  asa821-k8.bin

3      drwx  8192        19:03:16 Aug 20 2008  log

115    -rwx  3783553     10:50:24 Nov 24 2009  anyconnect-dart-win-2.4.0202-k9.pkg

116    -rwx  3191813     13:48:20 Nov 02 2009  anyconnect-win-2.4.0202-k9.pkg

117    -rwx  5199492     10:50:34 Nov 24 2009  anyconnect-linux-2.4.0202-k9.pkg

118    -rwx  4826572     10:50:40 Nov 24 2009  anyconnect-macosx-i386-2.4.0202-k9.pkg

119    -rwx  4901766     10:50:48 Nov 24 2009  anyconnect-macosx-powerpc-2.4.0202-k9.pkg

13     drwx  8192        18:03:42 Dec 07 2009  coredumpinfo

255426560 bytes total (205045760 bytes free)

So the question is...  huh?   I need help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
aabhatia Mon, 01/25/2010 - 11:34
Is this box in production?  If not,I would say go ahead and reload it to free
Up memory and then copy the image over.
Anders Frederiksen Wed, 02/03/2010 - 01:23


I also have this issue on a 5505 running 8.2(1).

Have tried through the ASDM and after a reboot, but nothing helps.

Does anyone have an idea on how to proceed with the upgrade?



Anders Frederiksen Fri, 02/26/2010 - 02:49


Still no joy when upgrading to 8.2(2). Even tried the asa822-4-k8.bin, but still the same error.

I get the following in my log when it tries to write the file to flash:

7     Feb 26 2010     11:42:58     711002                         Task ran for 10 msec, Process = Unicorn Admin Handler, PC = 8beab4b, Traceback =   0x08BEB37E  0x08424112  0x084242DA  0x0841E7C8  0x0841FF76  0x0842617D  0x08062413

Does anybody have any ideas on how to proceed?



EDIT: Never mind. The flash must have been corrupt. Suddenly all files disappeared, and after a format I could upload again. Weird shit...

woodjl1650 Sat, 09/04/2010 - 19:23

I recently received and ASA 5505...for some reason I deleted everything...Now I am reloading the ISO, but when I try and copy it over the disk0 I get this message: "%Error opening tftp:// (No such device)"

I have no idea on how to resolve this, I have formated the flash, and disk several times.  Please help.



IS.Networks Sun, 09/19/2010 - 15:36

If you are trying to upload via a console cable and you don't have the ethernet Interface up you may get this error.

davemit Wed, 09/21/2011 - 12:08

I had this issue trying to upgrade code on my 5505 (I am running with only 256MB RAM).

I couldn't get it to work until I had 25% memory available (via sh mem command).  To do this I disabled the threat detection features, and all VPN features and rebooted.  Was finally able to copy the new files over.

Hope this helps somebody!

rsculthorp Wed, 09/21/2011 - 15:45

Just for future reference, if you are having a problem loading files to flash that is removable (ASA 5505 is not). I have not opened up one of the 5505's so I am not sure, but I know that the 551 and 5520 the "internal" flash is just a CF card that is inside the case and can be removed if need be.  But with both these models you could just use the external flash card slot to load data as well.

It is not recommended by Cisco but you can pull the flash and connect it to a flash card reader and copy the files directly to it from your computer.  When it is put back in the device will see it with the new files.

I do not recommend doing it while the device is running, even though with older IOS versions that do not actively store and read data to the flash this can be done (2800 routers and such will do it without fail).

John Huthmaker Thu, 10/10/2013 - 14:56

I know this is an old post, but I wanted to let people know how I fixed this on my 5505 in case anyone ever finds this thread.  The problem is you cant copy over and ios unless there is enough free memory to hold the file while its being written to the flash.  What I found was that I had 256mgs of ram, and I had some crummy 8.4 ios that was a memory hog.  In order to upgrade to 9.1 I had to first roll back to a 7.x ios that fit within the memory of the device.  Then rebooted which freed up tons of memory, and then copied over the 9.1 flash.

Just back up your config before you start fiddling with it.


This Discussion

Related Content