Newbie routing help

Answered Question
Jan 25th, 2010

I inherited an 804 ISDN router and have been having an unpleasant time with the whole setup (had to call the telco twice to actually get the ISDN line working correctly, and then had to switch ISPs because the first didn't really support ISDN...) and now that I (allegedly) have those working, I cannot get the routing working.  I can ping IP addrs from the router console and the DHCP server is working - but I can't get from a PC to the internet.  Following is my config - hopefully someone can see the error of my ways.  Thanks for any assistance.

Router#show run
Building configuration...

Current configuration : 1922 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
boot buffersize 8080
boot system flash c800-sy6-mw.121-4
enable secret 5 $1$mjBQ$1lfLsQzW8JH1nN2gIuYNH.
!
!
!
!
!
!
dial-peer voice 1 pots
no call-waiting
ring 0
port 1
destination-pattern xxxxxxx
!
dial-peer voice 2 pots
no call-waiting
ring 0
port 2
destination-pattern yyyyyyy
!
pots country US
ip subnet-zero
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.1.151 192.168.1.255
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   domain-name rankin.local
   dns-server 208.67.222.222 208.67.220.220
!
no ip domain-lookup
ip name-server 208.67.222.222
ip name-server 208.67.220.220
isdn switch-type basic-ni
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface BRI0
no ip address
encapsulation ppp
no ip mroute-cache
dialer rotary-group 1
dialer-group 1
isdn switch-type basic-ni
isdn spid1 740xxxxxxx0101 xxxxxxx
isdn spid2 740yyyyyyy0101 yyyyyyy
isdn incoming-voice modem
compress stac
no cdp enable
!
interface Dialer1
ip address negotiated
encapsulation ppp
no ip split-horizon
no ip mroute-cache
dialer in-band
dialer idle-timeout 240
dialer string 2548002 class 56k
dialer hold-queue 10
dialer load-threshold 128 either
dialer-group 1
compress stac
no cdp enable
ppp authentication pap callin
ppp pap sent-username myusername password 7 13040702190D0D392E3679
ppp multilink
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 Dialer1
!
!
map-class dialer 56K
dialer isdn speed 56
dialer-list 1 protocol ip permit
snmp-server chassis-id JAD05300GJZ
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
end

Router#
I have this problem too.
0 votes
Correct Answer by Jon Marshall about 6 years 10 months ago

cgtyoder22 wrote:

I inherited an 804 ISDN router and have been having an unpleasant time with the whole setup (had to call the telco twice to actually get the ISDN line working correctly, and then had to switch ISPs because the first didn't really support ISDN...) and now that I (allegedly) have those working, I cannot get the routing working.  I can ping IP addrs from the router console and the DHCP server is working - but I can't get from a PC to the internet.  Following is my config - hopefully someone can see the error of my ways.  Thanks for any assistance.

Router#show run
Building configuration...

Current configuration : 1922 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
boot buffersize 8080
boot system flash c800-sy6-mw.121-4
enable secret 5 $1$mjBQ$1lfLsQzW8JH1nN2gIuYNH.
!
!
!
!
!
!
dial-peer voice 1 pots
no call-waiting
ring 0
port 1
destination-pattern xxxxxxx
!
dial-peer voice 2 pots
no call-waiting
ring 0
port 2
destination-pattern yyyyyyy
!
pots country US
ip subnet-zero
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.1.151 192.168.1.255
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   domain-name rankin.local
   dns-server 208.67.222.222 208.67.220.220
!
no ip domain-lookup
ip name-server 208.67.222.222
ip name-server 208.67.220.220
isdn switch-type basic-ni
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface BRI0
no ip address
encapsulation ppp
no ip mroute-cache
dialer rotary-group 1
dialer-group 1
isdn switch-type basic-ni
isdn spid1 740xxxxxxx0101 xxxxxxx
isdn spid2 740yyyyyyy0101 yyyyyyy
isdn incoming-voice modem
compress stac
no cdp enable
!
interface Dialer1
ip address negotiated
encapsulation ppp
no ip split-horizon
no ip mroute-cache
dialer in-band
dialer idle-timeout 240
dialer string 2548002 class 56k
dialer hold-queue 10
dialer load-threshold 128 either
dialer-group 1
compress stac
no cdp enable
ppp authentication pap callin
ppp pap sent-username myusername password 7 13040702190D0D392E3679
ppp multilink
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 Dialer1
!
!
map-class dialer 56K
dialer isdn speed 56
dialer-list 1 protocol ip permit
snmp-server chassis-id JAD05300GJZ
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
end

Router#

Firstly not sure what this route achieves -

ip route 192.168.1.0 255.255.255.0 Dialer1

so you may as well get rid of it. The other route ie. 0.0.0.0 0.0.0.0 Dialer1 is the one you need so leave that in.

The problem though is not a routing but a NAT issue. You need to NAT your inside addresses because 192.168.1.x are not routable on the internet. So add this to your config

inerface Dialer1 <-- under existing dialer1 interface add this ->

ip nat outside


access-list 101 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 101 interface dialer1 overload

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jon Marshall Mon, 01/25/2010 - 16:44

cgtyoder22 wrote:

I inherited an 804 ISDN router and have been having an unpleasant time with the whole setup (had to call the telco twice to actually get the ISDN line working correctly, and then had to switch ISPs because the first didn't really support ISDN...) and now that I (allegedly) have those working, I cannot get the routing working.  I can ping IP addrs from the router console and the DHCP server is working - but I can't get from a PC to the internet.  Following is my config - hopefully someone can see the error of my ways.  Thanks for any assistance.

Router#show run
Building configuration...

Current configuration : 1922 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
boot buffersize 8080
boot system flash c800-sy6-mw.121-4
enable secret 5 $1$mjBQ$1lfLsQzW8JH1nN2gIuYNH.
!
!
!
!
!
!
dial-peer voice 1 pots
no call-waiting
ring 0
port 1
destination-pattern xxxxxxx
!
dial-peer voice 2 pots
no call-waiting
ring 0
port 2
destination-pattern yyyyyyy
!
pots country US
ip subnet-zero
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.1.151 192.168.1.255
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   domain-name rankin.local
   dns-server 208.67.222.222 208.67.220.220
!
no ip domain-lookup
ip name-server 208.67.222.222
ip name-server 208.67.220.220
isdn switch-type basic-ni
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface BRI0
no ip address
encapsulation ppp
no ip mroute-cache
dialer rotary-group 1
dialer-group 1
isdn switch-type basic-ni
isdn spid1 740xxxxxxx0101 xxxxxxx
isdn spid2 740yyyyyyy0101 yyyyyyy
isdn incoming-voice modem
compress stac
no cdp enable
!
interface Dialer1
ip address negotiated
encapsulation ppp
no ip split-horizon
no ip mroute-cache
dialer in-band
dialer idle-timeout 240
dialer string 2548002 class 56k
dialer hold-queue 10
dialer load-threshold 128 either
dialer-group 1
compress stac
no cdp enable
ppp authentication pap callin
ppp pap sent-username myusername password 7 13040702190D0D392E3679
ppp multilink
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 Dialer1
!
!
map-class dialer 56K
dialer isdn speed 56
dialer-list 1 protocol ip permit
snmp-server chassis-id JAD05300GJZ
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
end

Router#

Firstly not sure what this route achieves -

ip route 192.168.1.0 255.255.255.0 Dialer1

so you may as well get rid of it. The other route ie. 0.0.0.0 0.0.0.0 Dialer1 is the one you need so leave that in.

The problem though is not a routing but a NAT issue. You need to NAT your inside addresses because 192.168.1.x are not routable on the internet. So add this to your config

inerface Dialer1 <-- under existing dialer1 interface add this ->

ip nat outside


access-list 101 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 101 interface dialer1 overload

Jon

cgtyoder22 Mon, 01/25/2010 - 17:04

Thanks much for the help. I am not near the router right now, but I will make the changes tomorrow and report back.

cgtyoder22 Wed, 01/27/2010 - 11:17

That fixed it. I can finally sleep at night without waking up drenched with sweat and screaming. Thanks again for the help.

Actions

This Discussion