How to set outbound proxy on 79xx phone?

Unanswered Question
Jan 26th, 2010

I have a Cisco 7945 IP Phone that I have been using with a PBX-in-a-box (Epygi Quadro 2x) by manually configuring a SEPxxxxxxxxxx.cnf.xml file and uploading it via TFTP to the phone.  I'd like to skip the PBX in-a-box and directly register the phone with Broadvoice, my SIP based VoIP provider.

Broadvoice "directly" supports the 7940/7960 phones, provided they are running firmware version P0S3-07-5-00, which uses the older configuration file format. My phone is currently running the latest SIP firmware SIP45.8-5-4S, and this can't be downgraded to P0S3-07-5-00.

The problem:  I seem unable to change the outbound proxy setting on the 7945.

I used a TFTP client to download the typical Broadvoice config file for a 7940 phone. It specifies the following relevant settings:

proxy_register: 1
outbound_proxy: "proxy.nyc.broadvoice.com";
outbound_proxy_port: 5060
proxy_emergency: "147.135.20.128"
proxy_emergency_port: 5060
proxy_backup: "147.135.20.128"
proxy_backup_port: 5060
line1_name: "mynumber";
line1_authname: "1234567890";  (my actual phone number instead of "1234567890")
line1_password: "password";    (my actual password instead of "password")
line1_shortname: ""
line1_displayname: ""
proxy1_address: sip.broadvoice.com
proxy1_port: 5060

Using this information, I configured a SEPxxxxxxxxxx.cnf.xml file with the following relevant settings:

<callManagerGroup>
  <members>
   <member priority="0">
    <callManager>
     <ports>
      <ethernetPhonePort>2000</ethernetPhonePort>
      <sipPort>5060</sipPort>
      <securedSipPort>5061</securedSipPort>
     </ports>
     <processNodeName>proxy.nyc.broadvoice.com</processNodeName>
    </callManager>
   </member>
  </members>
</callManagerGroup>
</devicePool>
<sipProfile>
  <sipProxies>
   <backupProxy>147.135.20.128</backupProxy>
   <backupProxyPort>5060</backupProxyPort>
   <emergencyProxy>147.135.20.128</emergencyProxy>
   <emergencyProxyPort>5060</emergencyProxyPort>
   <outboundProxy>5060</outboundProxy>
   <outboundProxyPort>proxy.nyc.broadvoice.com</outboundProxyPort>
   <registerWithProxy>true</registerWithProxy>
  </sipProxies>

  <sipLines>
   <line button="1">
    <featureID>9</featureID>
    <featureLabel>456-7890</featureLabel>
    <proxy>sip.broadvoice.com</proxy>
    <port>5060</port>
    <name>1234567890</name>
    <displayName>1234567890</displayName>
    <autoAnswer>
     <autoAnswerEnabled>2</autoAnswerEnabled>
    </autoAnswer>
    <callWaiting>3</callWaiting>
    <authName>1234567890</authName>
    <authPassword>password</authPassword>
    <sharedLine>false</sharedLine>
    <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
    <messagesNumber>00</messagesNumber>
    <ringSettingIdle>4</ringSettingIdle>
    <ringSettingActive>5</ringSettingActive>
    <contact>1234567890</contact>
    <forwardCallInfoDisplay>
     <callerName>true</callerName>
     <callerNumber>false</callerNumber>
     <redirectedNumber>false</redirectedNumber>
     <dialedNumber>true</dialedNumber>
    </forwardCallInfoDisplay>
   </line>
  </sipLines>

</sipProfile>


I can upload the new file to the phone just fine, but it never picks up the proxy settings, and therefore the phone won't register with Broadvoice.  Does anyone have any idea how I can get these proxy settings changed?  Thanks!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion