Multi link PPP across 2 DS3s (diff. vendor) query

Answered Question
Jan 26th, 2010

Hi All,

Existing P2P DS3 between 3 locations..

*******************************************************************

Site A: 7206 - 12.4

interface Serial1/0
description :DS3 to SIte B
ip address 10.10.1.1 255.255.255.252
dsu bandwidth 44210
scramble
serial restart-delay 0


 
Site B: 3845 - 12.4

Controller t3 3/0

!
interface Serial3/0
description :DS3 to SiteA
ip address 10.10.1.2 255.255.255.252
dsu bandwidth 44210
scramble

*******************************************************************

Simple & plain.. works perfect..;-). Planning to add another DS3 from different provider and looking to Multilink both DS3 for high BW.

Site A: 7206 - 12.4

!
interface multilink 10
description :Multilink to SIte B
ip address 10.10.1.1 255.255.255.252
ppp multilink
ppp multilink group 10
!
interface Serial 1/0
description :VENDOR1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 10
dsu bandwidth 44210
scramble
!
interface Serial 2/0
  description :VENDOR2
  no ip address
  encapsulation ppp
  ppp multilink
  ppp multilink group 10

  dsu bandwidth 44210
  scramble
!

Similar configurations on 3845 end as well.

Does the above configuration works for bonding both DS3s.? Also, if one DS3 goes down, another DS3 take over the traffic..?

TIA
MS

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 6 years 10 months ago

Hello MS,

I was meaning

ip ospf dead-interval {seconds | minimal hello-multiplier multiplier}

see

http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_osp1.html#wp1014268

it allows to have dead interval = 1 sec and hello interval = 1/ multiplier

so if multiplier is 4, hello interval becomes 250 msec

This should be supported on both devices.

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 01/26/2010 - 09:36

Hello MS,

two notes:

the two DS3 links provided by  different providers will have different delays, the difference in delay can play a role.

Multilinking two DS3 may cause an higher cpu usage in comparison to use them as two parallel L3 links.

I have some doubts the C3845 that is accreditated of two DS3 links can handle easy the bundle.

Said this configuration looks like correct, and I can report we have some multilinks with E1 members with different providers on international european circuits.

Unless you are going to have few very high traffic volumes flows between sites (DB replications or SAN mirroring  for example) the use of CEF based per destination load balancing provides good results.

Hope to help

Giuseppe

mvsheik123 Tue, 01/26/2010 - 10:13

Hi Giuseppe,

Thank you for the reply and points. The traffic is basically log shipping (relates to DB- to various servers) and Email/file server replications. No SAN replication at this time.

So if I treat them as two individual parallel links , with OSPF as routing protocol,  as the AD and cost is same, cisco default per-destination load-balance should take over. Is that correct?  Also, in this scenario as well, incase if one link goes down another will takeover the traffic.

Both routers have 'ip cef' enabled. Do I need to enable "ip cef load-sharing algorithm original' as well? my guess is no need to issue 'ip route-cache' on serial i/f on both rtrs as this is by default.

So in this scenario:

**************************************************************

7206 config:

interface Serial1/0
description : Provider#1
ip address 10.100.10.1 255.255.255.252
dsu bandwidth 44210
scramble
end

interface Serial3/0
description : Provider#2
ip address 10.100.10.5 255.255.255.252
dsu bandwidth 44210
scramble
end

And add the 10.100.10.4/30 n/w to OSPF process.

Same on the other end as well.

****************************************************************************

Thank you again.

MS

Giuseppe Larosa Tue, 01/26/2010 - 10:28

Hello MS,

your understanding is correct.

You should not need any change to CEF algorithm.

OSPF provides fault detection on a per link basis.

You may want to improve convergence time  by using sub-second hellos on a per link basis. (timers must match)

Hope to help

Giuseppe

mvsheik123 Tue, 01/26/2010 - 10:56

Thank you again...

You may want to improve convergence time  by using sub-second hellos on a per link basis:

You mean setting the ospf hellos under serial interface (ip ospf hello-interval) to something like 5..?

Thank you

MS

Correct Answer
Giuseppe Larosa Tue, 01/26/2010 - 11:09

Hello MS,

I was meaning

ip ospf dead-interval {seconds | minimal hello-multiplier multiplier}

see

http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_osp1.html#wp1014268

it allows to have dead interval = 1 sec and hello interval = 1/ multiplier

so if multiplier is 4, hello interval becomes 250 msec

This should be supported on both devices.

Hope to help

Giuseppe

mvsheik123 Tue, 01/26/2010 - 13:25

Hi Giuseppe,

What is the difference in having the links in Multilink and two parallel L3 (apart from high CPU in multilink) in my scenario?

Thank you

MS

Giuseppe Larosa Tue, 01/26/2010 - 13:29

Hello MS,

with multilink you can achieve per packet load balancing implemented by PPP multilink but the risk is higher cpu load specially to be noted on C3845.

with parallel L3 links load balancing results depends from traffic mix (variety of traffic) but cpu usage should be lower to be preferred for this reason.

Hope to help

Giuseppe

Actions

This Discussion