Help with C877 DSL router on internet?

Unanswered Question
Jan 26th, 2010

Hello,

I think I'm going crazy, I have confgured this Cisco 877 for the internet and it can ping google.com etc, but when I attach my laptop to the router in can't ping google's IP address.  It it like the router is fine and online, but the laptop can reach the router and that's it.  I though it might be my access list?

router#sh run
Building configuration...

Current configuration : 1908 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname andy
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 informational
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.5.5.1 10.5.5.10
!
ip dhcp pool clients
   import all
   network 10.5.5.0 255.255.255.0
   default-router 10.5.5.1
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username **** privilege 15 password 0 ****
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface ATM0
no ip address
ip virtual-reassembly
atm vc-per-vp 64
atm ilmi-keepalive
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
dsl operating-mode auto
cdp enable
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.5.5.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
no ip unreachables
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname [email protected]
ppp chap password 0 andywhite1
ppp pap sent-username [email protected] password 0 ******
ppp ipcp dns request
ppp ipcp wins request
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!
logging trap notifications
logging facility local4
access-list 102 permit ip 10.5.5.0 0.0.0.255 any log
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
password 3nt3r
login
!
scheduler max-task-time 5000
end

router#

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Tue, 01/26/2010 - 08:29

Hi Andy

ACcess list looks good to me.. i see the dhcp configs as:

p dhcp pool clients
   import all
   network 10.5.5.0 255.255.255.0
   default-router 10.5.5.1

do you ahve the DNS information ? Did your PC get a DNS IIP address when you connected over DHCP ? Can you do a ipconfig/all  and see if you have a valid DNS server ?

Raj

Andy White Tue, 01/26/2010 - 08:36

Thanks for your quick reply.

Shouldn't the laptop still be able to ping google.com on 209.85.229.105 regardless of DNS?

I can ping google.com and 209.85.229.105 from the router, but neither from the laptop.

Any logging I can turn on?

sachinraja Tue, 01/26/2010 - 08:50

Hi andy

Check for "show ip nat translation" to check if your local PC has a NAT rule associated with it (try browsing the site, instead of pinging). make sure you have a valid dns server when you browse.. Also when browsing, you can enable "debug ip nat" and if required "debug ip packet" (might give all ip packet debug.. make sure you dont have too much of traffic on this router when you enable debug ip packet.. first try the first two options, and as a last resort enable debug ip packet..

Hope this helps.. all the best

Raj

sachinraja Tue, 01/26/2010 - 08:57

Hi Andy

can you try configuring "ip nat outside" on the ATM interface too, and try if it works ?

Raj

Andy White Wed, 01/27/2010 - 00:27

I tried the "ip nat outside" on the ATM0 but still no luck.

I ran the "debug ip packet" and it displays this whenI try to get to google:

*Jul 20 16:13:14.419: IP: tableid=0, s=10.5.5.11 (Vlan1), d=10.5.5.255 (Vlan1), routed via RIB
*Jul 20 16:13:14.419: IP: s=10.5.5.11 (Vlan1), d=10.5.5.255 (Vlan1), len 78, rcvd 3

Is it trying to do an arp broadcast?

Ganesh Hariharan Wed, 01/27/2010 - 01:58

I tried the "ip nat outside" on the ATM0 but still no luck.

I ran the "debug ip packet" and it displays this whenI try to get to google:

*Jul 20 16:13:14.419: IP: tableid=0, s=10.5.5.11 (Vlan1), d=10.5.5.255 (Vlan1), routed via RIB
*Jul 20 16:13:14.419: IP: s=10.5.5.11 (Vlan1), d=10.5.5.255 (Vlan1), len 78, rcvd 3

Is it trying to do an arp broadcast?

Andy,

Try to check show ip nat translation in 871w router while browsing from laptop  if it is not happeing check out the below link on natting in cisco router hope it will clear your query !!

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/pppoenat.html

Ganesh.H

Actions

This Discussion