Problem adding directory number in CallManger version 7

Unanswered Question
Jan 26th, 2010

When I try to add a certain directory number to a phone device under a certain "all phones partition". It comes back with error. "Add failed. Cannot insert or update pattern. A Device Template exists with the same pattern and partition." I have looked under call routing-->directory number and call routing-->route plan route and I don't see this number anywhere.  I can add this number under and differnet partition without any problem. What is it talking about Device template? I am trying to add a directory number. I looked CTI route points as well and no reference to this certain number. Any ideas as where to look next?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
SCOTT JORDAN Tue, 01/26/2010 - 19:48

Yes I have done a search under unassigned DN's I don't see that number there.



dom_rozzi Wed, 01/27/2010 - 11:08


Sounds like you have a device template that has the DN explicitly assinged.  The templates are under Bulk Administration -> Phone -> Phone Template or it could be a User Device Profile (UDP) Template.  If you remove the DN from the template, you should be able to add it as a DN in Device -> Phone.



SCOTT JORDAN Wed, 01/27/2010 - 11:25


I see that we have templates under the Bulk Administration -> Phone -> Phone Template but they have names under the line template named "line template" there is no DN's assigned there. I don't see anything under the User Device Profile (UDP) template.



dom_rozzi Mon, 02/01/2010 - 09:42


The only other place I can think to check would be in the Route Plan Report.  Either under "All Patterns" or "Unassigned DNs".  You mentioned earlier that you tried the Unassigned DN's but have you tried the All Patterns with no criteria or partial criteria?

If that doesn't do to trick, perhaps TAC can shed some light on the error message and where the other templates are that might possibly have the DN/Partition you are trying in insert.



dwtcp Mon, 05/10/2010 - 06:45


I have just found the solution with no TAC needed!!

Obviously, it is a bug.

I am running

I faced the same error message.

"Update failed. Cannot insert or update pattern. A Device Template exists with the same pattern and partition."

Let's say for DN "1150" at partition "local_extension".

I navigated to the Bulk Admin->Phones->Phone Template and i found nothing.

So, i created one template and i added a line with Dn 1150 , to the partition that the problem existed (local_extension).

After i have created it ... i removed it

I was now able to add 1150 at partiton "local_extension" to the device i had the problem earlier!!

I might have created, 2 years ago that phone template and then erased it somehow because i didn't need it.

Maybe, it wasn't cleared correctly.

Best Regards

dev880812 Thu, 06/14/2012 - 08:24

Thanks for posting the solution DWTCP!!

I was struggling from last two days in my lab and could not able to fix the issue. I tried number of solutions available on net.

Finally this worked for me. thank you !!!

warm regards


This Discussion