DNS issue with Cisco VPN Client 5.0.06.0160 and Windows 7

Unanswered Question
Jan 27th, 2010

Hello,

I have a strange issue with DNS resolution on my Windows 7 Professional with a Cisco VPN Client. I have configured an ASA5510 with version 8.x for VPN Remote Access. I configured split tunneling. The DNS Server configured is the internal DNS server.

When I connect from outside, it all works great, I can ping everywhere I want, but as I try to resolve an internal DNS Name it doesn't work. But external Names do work.

Then I started Wireshark to see, what happens to my DNS queries --> As long as the trace is running on the VPN interface I can resolve internal names?!?! As soon as I stop the trace nslookup gives back timeouts.

Does anybody have an idea what this can be?

Regards

Magnus

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
henryscheinnl Wed, 02/10/2010 - 00:34

Hello Preinerm,

We had the same problem.

Resolving internal hosts went wrong because the external (internet) DNS server does resolve it. Ofcourse to the wrong IP.

I just updated the Cisco VPN Client from version 5.0.00.0340 to 5.0.05.0290.
This solved the problem for us.

Cheers

henryscheinnl Thu, 03/04/2010 - 08:02

He Preinerm,

The last message we brought you is not correct.

Updating the client solved this issue for a couple of users but after some days they ha the problem again.

After some investigation it was the Split DNS value.

We have entered the internal domains here so that DNS requests for hosts in the LAN are resolved via the internal DNS servers.

Hope this helps.

Actions

This Discussion