LMS2.6/RME4.0.5/SWIM : upgrade ios works but without reboot

Unanswered Question
Jan 27th, 2010
User Badges:

Hi,


Customer has tried to upgrade ios on 3650 EMI, it works but switch doesn't reboot, option "Reboot immediately after downloading" was check.

Snmp write community is ok and snmp

old ios c3560-ipservices-mz. 122-25.SEE2.bin

new ios : c3560-ipservicesk9-tar.122-46.SE.tar

Many thanks, Elisabeth






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 01/27/2010 - 14:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You need to configure:


snmp-server system-shutdown
ebezombes Wed, 01/27/2010 - 14:52
User Badges:

I think that customer has configured this command, I will verify with customer.

If this command is configured, which debug can we activate for swim ?

Joe Clarke Fri, 01/29/2010 - 17:21
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You can check the job's swim_debug.log, but I would highly doubt that if the job was successful, that an SNMP restart was not attempted.  However, if the job was reported as to have failed, the log will indicate why.

ebezombes Wed, 02/03/2010 - 03:48
User Badges:

You are right, job is failed when reboot failed.

You can find swim_debug.log, we can see error with snmp set request but credential are ok.

Attachment: 
Joe Clarke Wed, 02/03/2010 - 15:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The SNMP SET to do the reload hit a timeout.  The credentials look to be okay, but something could be intercepting the SET and dropping it.  It would be helpful to see a sniffer trace of the SWIM job filtering on all SNMP traffic between the switch and the server.  Additionally, getting the "debug snmp packet" output from the switch while the SWIM job is running would confirm the SNMP packet is actually making it to the device.

ebezombes Wed, 04/14/2010 - 14:20
User Badges:

Hi,


We have increase snmptimeout to 5 seconds and installed RME 4.0.6, now it works but I don't know if this is the snmptimeout modification or RME 4.0.6 which has correct this issue.

I have an other issue with swim, I am going to open a new thread.


Thanks, Elisabeth

Joe Clarke Wed, 04/14/2010 - 23:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You need to have the following configured on your switch:


snmp-server system-shutdown

Actions

This Discussion