HSRP and Backup Interface

Unanswered Question
Jan 28th, 2010

Hi, I want to configure one router with a backup interface and the problem is that the router don´t permit me to configure HSRP !

This is the primary interface configuration:

interface GigabitEthernet0/0
description ### Trunk ##

backup interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/0.1
description ### DMZ ###
encapsulation dot1Q 1
ip vrf forwarding EXAMPLE
ip address 172.18.5.105 255.255.255.224
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1200
standby 1 ip 172.18.5.100
standby 1 priority 90
standby 1 preempt

!

And when i want to enable HSRP on the backup interface i have this message:

Router(config-subif)#interface GigabitEthernet0/1.1
Router(config-subif)#standby 1 ip 172.18.5.100
% Address 172.18.5.100 in group 1 - interface GigabitEthernet0/0.1

The rest of the configuration is the same of the main interface.

Does any one knows if i can have a backup interface with the same configuratión of the main interface ?

thanks !!

Pablo.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Thu, 01/28/2010 - 07:25

Hi, I want to configure one router with a backup interface and the problem is that the router don´t permit me to configure HSRP !

This is the primary interface configuration:

interface GigabitEthernet0/0
description ### Trunk ##

backup interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/0.1
description ### DMZ ###
encapsulation dot1Q 1
ip vrf forwarding EXAMPLE
ip address 172.18.5.105 255.255.255.224
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1200
standby 1 ip 172.18.5.100
standby 1 priority 90
standby 1 preempt

!

And when i want to enable HSRP on the backup interface i have this message:

Router(config-subif)#interface GigabitEthernet0/1.1
Router(config-subif)#standby 1 ip 172.18.5.100
% Address 172.18.5.100 in group 1 - interface GigabitEthernet0/0.1

The rest of the configuration is the same of the main interface.

Does any one knows if i can have a backup interface with the same configuratión of the main interface ?

thanks !!

Pablo.

Hi Pablo,

As the error message clearly says the group ip is assigned to GigabitEthernet0/0.1 so you are assiging to different sub interface of different switch.so try to change the sub interface in second switch and assign the standby ip.

HSRP groups on subinterfaces must have a group number unique among all       other groups on all subinterfaces on the same main interface.

Hope to help !!

Ganesh.H

Pavel Bykov Thu, 01/28/2010 - 07:48

Hi.

1. You will not be able to configure even IP address in the same subnet on another interface. That's principle of routers.

2. HSRP is made so you are backing up one router with the other, not one interface with the other. So this will work if you have two routers.

3. You can make what you want to do, but you would have to use VRF. VRFs will separate all the information and create two logical routers.

4. You can also make an EEM script that unshuts the other interface when the first one goes down

But basic recommendation is don't do backup interface this way. If you want backup facing users, do it using two routers.

If you want backup facing service provider, use routing protocols, including static routing.

What is the purpose of the backup in this case?

Actions

This Discussion