Router prefers EIGRP over OSPF

Unanswered Question
Jan 28th, 2010

I have a network that is advertised with both EIGRP (Internal) and OSPF (External) and I want the router to take the OSPF route but it is ignoring it and taking EIGRP.


10.16.4.0/22 is configured on the remote router which has a MPLS (5Mbps / OSPF) and a DMVPN (1.5 Mbps / EIGRP) connection. I am no RP expert and am trying to learn this but here are my show ip routes from the local router.





Routing entry for 10.16.4.0/22 (when running only OSPF on the remote router)
  Known via "ospf 1", distance 110, metric 20
  Tag Complete, Path Length == 1, AS 3549, , type extern 2, forward metric 2
  Redistributing via eigrp 10, eigrp 16855
  Advertised by eigrp 10 metric 32000 100 255 1 1300
                eigrp 16855 metric 32000 100 255 1 1300
  Last update from 172.27.250.1 on Serial3/0, 00:00:55 ago
  Routing Descriptor Blocks:
  * 172.27.250.1, from 208.50.40.223, 00:00:55 ago, via Serial3/0
      Route metric is 20, traffic share count is 1
      Route tag 3489664477


Routing entry for 10.16.4.0/22 (when running both OSPF and EIGRP on the remote router)
  Known via "eigrp 10", distance 120, metric 12828160, type internal
  Redistributing via eigrp 10, eigrp 16855, ospf 1
  Advertised by eigrp 16855
                ospf 1 subnets
  Last update from 10.48.12.36 on Tunnel1, 00:08:01 ago
  Routing Descriptor Blocks:
  * 10.48.12.36, from 10.48.12.36, 00:08:01 ago, via Tunnel1
      Route metric is 12828160, traffic share count is 1
      Total delay is 500100 microseconds, minimum bandwidth is 100000 Kbit
      Reliability 238/255, minimum MTU 1300 bytes
      Loading 1/255, Hops 1



Thanks, I appreciate the help!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
milan.kulik Thu, 01/28/2010 - 12:34

Hi,


usually, this would be an adminstrative distance problem, as OSPF has AD 110 by default and EIGRP 90 (see http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094195.shtml for details.)


But it looks like you modified EIGRP AD to 120 already.

So I've got a feeling the 10.16.4.0/22 prefix is not present in the OSPF database when you are running both OSPF and EIGRP on the remote router.


Can you check if the prefix is advertised by OSPF (sh ip ospf database...  command)?


Have you changed the EIGRP AD on the remote router, too?


HTH,

Milan


BrianMitchellTX Thu, 01/28/2010 - 12:58

Thank you for the quick response!


I did find the default administrative distances chart and have been using that as my reference and I added a distance


Here is the result from my sho ip osp database | inc 10.16.4.

10.16.4.0       172.27.250.2    39          0x80000001 0x00952B 0


I ran that command on the local router (the one that keeps preferring EIGRP).


Here is my configuration from the remote router:


router eigrp 10
network 10.16.4.1 0.0.0.0
network 10.48.12.36 0.0.0.0
network 10.100.1.61 0.0.0.0
distance eigrp 120 120
passive-interface default
no passive-interface Tunnel1
!
router nhrp
!
router ospf 1
router-id 172.27.250.70
log-adjacency-changes
redistribute eigrp 10 subnets
network 172.27.250.68 0.0.0.3 area 0
network 172.29.20.0 0.0.0.255 area 2
network 172.29.22.0 0.0.0.255 area 2



Here is the configuration from the local router:


router eigrp 10
redistribute connected
redistribute eigrp 16855
redistribute ospf 1 metric 32000 100 255 1 1300
passive-interface default
no passive-interface Tunnel1
network 10.48.12.1 0.0.0.0
distribute-list 10 out
distribute-list 10 in
distance 120 10.48.12.36 0.0.0.0 VPN2.0HUB
no auto-summary


router ospf 1
router-id 172.27.250.2
log-adjacency-changes
redistribute eigrp 10 subnets
redistribute eigrp 16855 subnets
passive-interface default
no passive-interface Serial3/0
network 172.27.250.2 0.0.0.0 area 0
distribute-list DENY_DEFAULT_ROUTE in


Standard IP access list VPN2.0HUB
    10 permit 10.16.4.0, wildcard bits 0.0.3.255 log


Thanks again!

milan.kulik Fri, 01/29/2010 - 02:44

Hi,


can you please investigate more details regarding the 10.16.4.0 record in the OPSF database?

What kind of LSA is it?

Is it visible via sh ip ospf data ext, e.g.?

I've got a feeling it's there only because redistributed from EIGRP by the local router, but not received by OSPF from the remote router, isn't it?

Are that two routers OSPF neighbours at the moment (sh ip ospf nei)?


HTH,

Milan

Actions

This Discussion