SPA504G Handset/Speaker Volume

Unanswered Question
Jan 28th, 2010

Is there any way to increase the volume of the 504G other than the volume control button on the phone?  My customer is complaining that the max volume setting obtained is not loud enough.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Steven Smith Fri, 01/29/2010 - 09:52

What firmware are you running?  There are a few volume fixes for the SPA phones in the 7.4.3 firmware.

aapexisinc Fri, 01/29/2010 - 10:06

They are running 7.1.3, but I seem not to be able to update the phone loads using CCA 2.2.1; drag and drop does not work.

Steven Smith Fri, 01/29/2010 - 10:11

What error are you getting when you do this?  You must have no TFTP servers running when you do this.  Also, disable the firewall and antivirus on your computer.  I have tried this before with CCA 2.2.1, so I know that it works. 

Also, make sure you are using the .bin file.

One other thing, can you provide a show flash: all


aapexisinc Fri, 01/29/2010 - 10:34

I just get a circle with a line through it when I try to drag onto the topology view.  No other tftp servers are running, and disabling firewall/antivirus makes no difference.

Steven Smith Fri, 01/29/2010 - 10:45

Do you get an error at the bottom of the screen at all?  Can you post your CCA log?

aapexisinc Fri, 01/29/2010 - 10:54

No errors at all... it won't let me drag it onto the topology view...

How do I get at the CCA log to post it?  It shows nothing reagrding my attempt to drag and srop, though... just the basic startup messages.

Steven Smith Fri, 01/29/2010 - 11:01

Help -> Support Information -> Troubleshooting Log.

Try it one more time, then get the log.

Steven DiStefano Fri, 01/29/2010 - 13:34

I see that little circle with the line through it too...but when I release the file on the UC540 topologu ICON, it works.

Did you try that too?

aapexisinc Fri, 01/29/2010 - 18:42

Yes, I've tried that, but nothing happens.  You're dropping it directly on the uc540 icon, right?

Steven Smith Mon, 02/01/2010 - 13:25

Can you manually copy the file to flash using tftp?

From a UC500...

copy tftp flash:/phones/5x5

(pick the file etc)

config t

tftp-server flash:/phones/5x5/spa5x5-7-4-3.bin alias spa5x5-7-4-3.bin


load 501G spa5x5-7-4-3

load 502G spa5x5-7-4-3

load 504G spa5x5-7-4-3

load 508G spa5x5-7-4-3

load 509G spa5x5-7-4-3

no create cnf-files
create cnf-files
Reboot the phone.
aapexisinc Mon, 02/01/2010 - 14:28

I did that, after giving up on the drag-and-drop.  The phone firmware is updated, but I don't notice any significant improvement in the volume.

Steven Smith Mon, 02/01/2010 - 14:33

Would you mind opening a case for this problem?  If there is still a volume problem, it would best to get a case opened for this.

stacy.thompson Fri, 01/29/2010 - 09:53

My client's complain of the same issues with these handsets.

Upgrading the phone firmware to latest version makes some improvement, but most times they still think it's too quite or 'tinny'.

I am interested in hearing Cisco's response to your post.



This Discussion