CUPS7 OCS2007 & CUCM7 - RCC not working

Answered Question
Jan 28th, 2010

Hi All,

I have been pulling my hair out trying to get remote call control to function.

I have gone through the deployment documentation as much as possible and still receive the following errors....

I have green lights on all diagnostic tests from within CUPS, have set the AD strings, Authorised host on OCS uses an IP address and not FQDN and SIP truck etc etc but there is nothing on google about "doesn't point at proxy" or "91608 is a guessed E164 user, number expansion on it failed" which are errors I get via the Real Time monitoring tool when logging into communicator.

When trying to dial a number I get the "cannot locate" error, no presence information updates when I pick up the handset and within communicator I only have the option to use "communicator call".

We use Extension mobility in CM7

Anyone who can point me to the answer is a legend!

----------------------------------------

Via: SIP/2.0/TLS 10.20.45.53:4675;ms-received-port=4675;ms-received-cid=A300
From: "Todd Cummings - LNCORP"<sip:[email protected]>;tag=e93239d6ec;epid=ea4f3676d5
To: <sip:[email protected]>
Call-ID: 7638e2fe32a3447cb01ccbb64d7bafc8
CSeq: 1 INVITE
Contact: <sip:[email protected];opaque=user:epid:D8boI6okjVel7zAzgMiSoAAA;gruu>
User-Agent: UCCAPI/3.5.6907.9 OC/3.5.6907.34 (Microsoft Office Communicator 2007 R2)
Content-Disposition: signal;handling=required
Supported: timer
Supported: histinfo
Supported: ms-safe-transfer
Supported: ms-sender
Supported: ms-early-media
ms-keep-alive: UAC;hop-hop=yes
Allow: INVITE, BYE, ACK, CANCEL, INFO, UPDATE, REFER, NOTIFY, BENOTIFY, OPTIONS
Content-Type: application/csta+xml

<?xml version="1.0"?>
<RequestSystemStatus xmlns="http://www.ecma-international.org/standards/ecma-323/csta/ed3"><extensions><privateData><private><lcs:line xmlns:lcs="http://schemas.microsoft.com/Lcs/2005/04/RCCExtension">tel:91608;phone-context=dialstring</lcs:line></private></privateData></extensions></RequestSystemStatus>


|<CLID::StandAloneCluster><NID::Auscup11><LVL::All><MASK::ffff>
01/29/2010 17:52:58.713 ESP|[Fri Jan 29 17:52:58 2010] PID(13751) mod_sip_numexpand.c(818) 91608 is a guessed E164 user, number expansion on it failed.

|<CLID::StandAloneCluster><NID::Auscup11><LVL::All><MASK::ffff>
01/29/2010 17:52:58.713 ESP|[Fri Jan 29 17:52:58 2010] PID(13751) mod_sip_numexpand.c(818) 91608 is a guessed E164 user, number expansion on it failed.

|<CLID::StandAloneCluster><NID::Auscup11><LVL::All><MASK::ffff>
01/29/2010 17:52:58.714 ESP|[Fri Jan 29 17:52:58 2010] PID(13751) mod_sip_numexpand.c(788) URL host my-domain.com.au doesn't point at proxy, no number expansion on user todd.cummings

|<CLID::StandAloneCluster><NID::Auscup11><LVL::All><MASK::ffff>
01/29/2010 17:52:58.714 ESP|[Fri Jan 29 17:52:58 2010] PID(13751) mod_sip_numexpand.c(818) 91608 is a guessed E164 user, number expansion on it failed.

|<CLID::StandAloneCluster><NID::Auscup11><LVL::All><MASK::ffff>
01/29/2010 17:52:58.714 ESP|PID(13751) sip_sm.c(1165) Sent 432 bytes TCP packet to 10.20.100.125:64451
SIP/2.0 100 Trying
Via: SIP/2.0/TCP 10.20.100.125:64451;received=10.20.100.125;branch=z9hG4bK47E2D253.535DBECA7053DC6A;branched=FALSE, SIP/2.0/TLS 10.20.45.53:4675;ms-received-port=4675;ms-received-cid=A300
Call-ID: 7638e2fe32a3447cb01ccbb64d7bafc8
From: "Todd Cummings - LNCORP"<sip:[email protected]>;tag=e93239d6ec;epid=ea4f3676d5
To: <sip:[email protected]>
CSeq: 1 INVITE
Content-Length: 0

-----------------------------------------------

Let me know your questions

Thanks

Todd

I have this problem too.
0 votes
Correct Answer by htluo about 6 years 11 months ago

CUPS version prior to 7.0.6 has many RCC bugs.  I would recommend you upgrade to 7.0.6 before troubleshooting.

On MOC side, don't forget to install the "Phone Selector" plug-in from Cisco.

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
htluo Fri, 01/29/2010 - 07:41

1) What version is CUPS?

2) Could you upload the CUPS SIP proxy log with "CTI Gateway" option turned on?  We need the logs since MOC logged in to the point when call control failed.

3) We need MOC login ID, IP phone extension, and MAC address.

Thanks!

Michael

lionnathan Sun, 01/31/2010 - 13:01

Hi Michael,

Thanks for the reply...

We use CUPS 7.0.2, my extension is 91608 and my user id is tcumming.

The profile EM-tcumming is the name of the extension mobility profile and the MOC login is my userid with the sign in address being my email address.

Not sure what mac address you are after? PC, Phone or server?

The error invalid device for EM-tcumming seems interesting... are we looking at a call manager misconfiguration?

Looks like OCS is talking to CUPS which then talks to CUCM ok.

Cheers

Todd

Correct Answer
htluo Sun, 01/31/2010 - 13:03

CUPS version prior to 7.0.6 has many RCC bugs.  I would recommend you upgrade to 7.0.6 before troubleshooting.

On MOC side, don't forget to install the "Phone Selector" plug-in from Cisco.

Michael

lionnathan Sun, 01/31/2010 - 13:35

Hi Michael,

Yeah I read about the phone selector plugin for when you have multiple devices but I couldn't find anywhere to grab it.

Google and cisco site searchs resulted in no results.

I'm probably making a simple mistake which is causing the problem... are you able to post a link to the download?

lionnathan Sun, 01/31/2010 - 15:05

Hi Michael,

The plugin has been downloaded and installed with the cupsfqdn variable passed on the plugin installation.

It seems that a new issue has been found where nobody can login to the user options page.

Trying to sovle this one now and then I can see what happens with the errors after I login the plugin.

I'm assuming the issue here is the LDAP Server or LDAP profile configuration under CUPC?

*****(Update)*****

I set the LDAP server and profile then did a "utils service restart Cisco Tomcat" from the command line.

I can now login to the user options page.

*****Update******

Michael,

After logging into the plugin I get a "This page is not yet implemented" error message.

The very first time I tried opening OCS after installing the plugin I got the login page and once I entered the details I got the CUPS user options webpage  (for example, it was the same as what I normally see in the full browser but showing in the tiny screen under OCS) which I dont believe is what I am supposed to be seeing according to... http://docwiki.cisco.com/wiki/Cisco_Unified_Presence%2C_Release_7.x_--_How_to_Deploy_the_Phone_Selection_Plug-in#How_to_Deploy_the_Phone_Selection_Plug-in

How do I get the plugin to function correctly. I have entered the correct FQDN when installing the plugin and I have uninstalled / reinstalled it with no change.

lionnathan Tue, 02/02/2010 - 21:59

SUCCESS!!!

After upgrading from 7.0.2 to 7.0.6 it started fulling functioning.

The setting "Microsoft server type" under [Application -> Deskphone control -> settings] that is mentioned in the documentation is not in 7.0.2 but it appeared after the upgrade.

The plugin also started working correctly.

Thanks for the heads up on the buggy version Michael!

Cheers

Todd

Actions

This Discussion

Related Content