UCCX 7 - CTIStorageSever messages in event log

Unanswered Question


On one of our UCCX 7 HA clusters we are seeing the following errors in the event log

Event ID: 2

Source: CTIStorageServer

AcmiCInt0001 Failed to send message to the cti server. Error(failed to send message to the cti server).

Where this deployment is located there is an onsite CUCM subscriber running AXL and CTI services.  The CUCM configuration in UCCX only references this server for CTI and no other servers as the others are located remotely across a WAN.

Does this message in the event log present a problem?

The other thing I have noticed on this UCCX cluster is that when I run the Cisco Desktop WorkFlow Administrator and select the call centre and then perform a directory service sychronise, I get a pop up telling me that at least one error occured. When I examine the event log I can see the following message:

Event ID: 2

Source: DirAccessSynSvr

AmciInt0001 Failed to send message to the cti server. Error(failed to send message to the cti server).

Pretty similiar to the first error message above.

I should point out that I am using the same AXL user account for different UCCX deployments connected the same CUCM cluster but I don't think this is the problem.

Any help appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
cesar_ortega Mon, 02/15/2010 - 03:33
User Badges:


Got just the same issue.

My UCCX version: 7.0.1SR4_Build443.

Event viewer also displays the following messages:

Event Type:    Error
Event Source:    CTIStorageServer
Event Category:    None
Event ID:    4
User:        N/A
AcmiClnt2004 Error occured when receiving message from cti server. Error(15:failed to read from socket).

Thanks in advance.


I did manage to resolve this issue but it was a long process and I tried many things.

The first thing I tried was to recreated the CTI ports. I also used different user accounts that the ones I originally used.

I also uninstalled the jtapi client from the UCCX server and downloaded and installed the version from the admin page.  The funny thing was when I restarted the server and loaded up the admin page it complained that the jtapi versions were inconsistent.  I allowed it to update and after another restart the problem disappeared.

Hope this helps you out.


cesar_ortega Mon, 02/15/2010 - 08:55
User Badges:


Thanks a lot for your reply.

Could you tell me your exact UCCX version?

When you faced this problem, were you using any custom developed java classes within your UCCX scripts?

I'm not sure whether this is the problem or not, but a few days ago I included a new "Set" step in my script which uses a custom java class I created..

Any help will be appreciated.

Thanks in advance.


Caravan NOC Thu, 11/18/2010 - 09:22
User Badges:

Hello everybody.

I had the same errors. In my case the problem was in unsynchronized CM Telephony Triggers between CUCMs and UCCX. So I did Data Resync, found out which exactly triggers are not synchronized and deleted it manually from CUCM (UCCX couldn't sync it automatically). After that I restarted UCCX services, and the error had gone.


This Discussion