Fax (over SIP trunks) Issue

Unanswered Question
Jan 29th, 2010

Has anyone experienced an issue with fax (over SIP trunks) when after upgrading to 8.0?  We recently upgraded our UC-520 to 8.0 and ever since then our faxes (both inbound & outbound) have not been working.  The SIP messages show a 500 server error so it appears that a setting was changed somewhere after the upgrade.  The fax machine is connected to FXS 0/0/0 and tried to change configs associated to that port but nothing has worked so far.  Attached are the logs and pertinent voice configs.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Mon, 02/01/2010 - 09:34

The ephone associated with port 0/0/0 does not have a button assigned:

         !

ephone  1

device-security-mode none

mac-address B8FA.C518.0000

max-calls-per-button 2

type anl

!

You need to add the 'button 1:5" statement.

Marcos

Jerome Daroya Mon, 02/01/2010 - 11:58

I have added the buttons statement but still no luck.  I also noticed that the ephone was not registered so I have added "service stcapp" on dial-peer voice 1 pots.  Also no luck with the fax calls getting through.

Maulik Shah Wed, 02/03/2010 - 10:16

Hi Jerome

  Can you gather the below info:

1. On CCA, Monitor > Reports > IOS Exec Commands > enter "show ephone register" and gather that output

2. On CCA, Troubleshoot > Telephony Diagnostics > Voice Troubleshooting Log and gather logs for Dial Plan and VoIP (SIP) when you make an inbound call. CLI debugs needed are deb ccsip message / deb voip ccapi inout / deb voip dialpeer inout

Another option as a workaround via CLI you can test is:

dial-peer voice 1 pots

  no service

  destination-pattern 5625084920

See if that helps.

Maulik Shah Thu, 02/11/2010 - 15:09

Can you add 208.94.159.10 to the list of allowed SIP Trunk IP addresses (CCA - go to SIP trunk tab and click on Advanced)

Jerome Daroya Thu, 02/11/2010 - 15:30

i've added the IP below and still getting the lines are busy message.  but after looking at ACL 104, it looks like the box is already allowing port 5060 to & from ANY.

Maulik Shah Thu, 02/11/2010 - 16:23

Can you send the latest config and log for one failed call please? This new IP address entry is added to access-list 2 which looks at the SIP Via headers, not the source IP of the SIP message which is what access-list 104 does. However would strongly recommend to lock this down on access-list 104 as shown in section 4.4.2 in below link:

https://www.myciscocommunity.com/servlet/JiveServlet/previewBody/1560-102-1-1933/UC500-SIPTrunking-Wiki-062008.pdf

Maulik Shah Thu, 02/11/2010 - 18:19

Not sure how this got added but I see the DID for inbound fax is set to extension 211:

ephone-dn  5  dual-line
number 211 secondary 5625084920 no-reg both

Can you change this as below via CLI:

config t

ephone-dn 5

  preference 10

and re test the call. If this fails - need below logs:

show dialplan number 5625084920

for one failed call:

deb ccsip all

deb voip source-group

deb voip dialpeer inout

deb voip ccapi inout

Maulik Shah Thu, 02/11/2010 - 22:07

Running into a known issue with UC500 on 8.0.0 software pack (IOS version 15.0.1XA) - details can be found by logging into link below

http://www.cisco.com/cgi-bin/Support/Bugtool/launch_bugtool.pl

ID CSCtc86342

In terms of a fix - an official software pack will be released at the end of this month with this fix. If you need an interim image please send me your cisco.com user ID or you run the previous image.

Maulik Shah Fri, 02/12/2010 - 09:30

No problem - you should get an email in an hour with instructions to download this file. Let us know how that went.

Jerome Daroya Tue, 02/16/2010 - 11:26

Thank you...  The image worked...  I was getting busy signal at first but after making some changes to the config i was able to receive fax calls.

Actions

This Discussion