Cisco configuration professional 2.1 hibernate error

Unanswered Question
Jan 29th, 2010
User Badges:

When try try to run CCP 2.1 a got the following error:

org.hibernate.exception.GenericJDBCException : Cannot open connection


CCP 2.0 worked fine.


I am using Windows XP SP3.


¿Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
keith.craig Sun, 01/31/2010 - 12:07
User Badges:

I am having the same problem. Just installed CCP 2.1 and

on startup get the error.

jsandraschitz Mon, 02/01/2010 - 06:56
User Badges:

I have the same problem  on windows server 2003 with Cisco configuration Professional ccp 2.1

org.hibernate.exception.GenericJDBCException : Cannot open connection

mark.strey Mon, 02/08/2010 - 13:56
User Badges:

I had the same Problem. CCP uses port TCP/8009 which was already used by vmware workstation on my workstation. I stopped the service "vmware server web access" and reinstalled the CCP again. After this it is working....

Mark Walters Mon, 02/15/2010 - 20:07
User Badges:


Hi All -


Same problem here.  Windows 7 32-bit, Cisco Configuration Professional 2.1, Java 1.6.0_17-b04, Internet Explorer 8.0.7600.


TCP Ports 1099, 2038, 8006, 8009, 8600, and some high ephemerals are listening (is all that really necessary?) due to the "CiscoCPEngine.exe" process.  Host firewall is disabled.


Any ideas?


Thx

Mark

Mark Walters Mon, 02/15/2010 - 21:00
User Badges:

Ok, got it working.  Here's what i did, hope it helps:


Downgraded Java 1.6.0_17 to 1.6.0_16.  Downloaded the older release from Sun, installed.  Both version were then installed.  Bring up the Java console (from Control Panel -> Java), go to Java, View, and de-select 1.6.0_17.  1.6.0_16 was my only version left selected.


Reboot, re-install Configuration Professional.  If it works then great, if not try this:


http://a-developers-notes.blogspot.com/2007/05/downgrade-default-jre-on-windows-xp.html


Reboot, re-install Config Prof again.


Note that if you use GNS3/Dynamips then you'll want to update the Java runtime parameters (same location as above) with this:


Xmx256m -Dsun.java2d.d3d=false


cheers

mark

emergismsh Thu, 03/04/2010 - 07:48
User Badges:

I am disapointed to see that some resolution are from outside newsgroup when our friends from Cisco should resolve this and guide us into it since it comes from their application. I am not having issues with other JRE applications in my workstation and now because I would have to downgraded or altered JRE, it would probably impact my other apps?


Patching such to downsize JRE as a requirement does not demonstrate a good quality product from Cisco.


Since a good product relies on a "version and higher requirements" concept, JRE developpers should correct their applications accordingly and document Q&A regarding issues from their application.


What is the process to address that directly to our Cisco friends?

jamarsal59 Fri, 03/05/2010 - 06:38
User Badges:

I download ccp 2.1 again, the file date is Feb 25, 2010, and now it works.

sadiqallawati Sun, 03/14/2010 - 05:57
User Badges:

Thanks amuentener,


It worked. Followed the link on Cisco website and this what I did.


To resolve this problem, you must modify the hibernate.properties file. Do the following:

1. Go to C:/Program Files/Cisco Systems/CiscoCP/webapps/ROOT/WEB-INF/classes/hibernate.properties

2. Open the hibernate.properties file in Notepad, and then search for the following statement:

hibernate.connection.url = 
jdbc:derby:${CP_ROOT_DIR}/cpdb

3. Replace the statement with the following:

hibernate.connection.url = 
jdbc:derby:C:/Program Files/Cisco 
Systems/CiscoCP/webapps/ROOT/WEB-INF/cpdb

4. Relaunch Cisco CP.

Actions

This Discussion