MULTICASTING - PROBLEM

Answered Question
Feb 1st, 2010

Dear All,

I am trying multicast video stream in my network but it is not working between Vlans. But its works fine in the same vlan.

Using VLC for video straming. Router, switch and pcs are connected as given in the below link.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a00800b0871.shtml

Router - Cisco 2821

Swicth - Cisco 2950

Pls guide me to make this works.

Regards,

Gopi

I have this problem too.
0 votes
Correct Answer by Mohamed Sobair about 6 years 11 months ago

Hi,

The router is detecting IGMP hosts to join group 239.100.100.100.

and you have enable multiccast routing + pim on all router interfaces. what is the ttl value used by VLC to stream the multicast?

The (Sh ip mroute) on the router doesnt provide the desired result?  So there is a problem.

Try to ping the group from the server , and do (sh ip mroute) on the router. statically join group 239.100.100.100 on the router interface

pls post back the result..

HTH

Mohamed

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Mohamed Sobair Mon, 02/01/2010 - 03:29

Hi,

Could you attach your current Netwok design in order to get better help?

HTH

Mohamed

NSG_POLARIS Mon, 02/01/2010 - 04:20

Hi,

I am trying this set up in the set lab before putting in to the production environment. Pls find the attached document.

Router Configuration

ip multicast-routing

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

ip address 172.16.1.1 255.255.0.0

!

interface GigabitEthernet0/1.17

encapsulation dot1Q 17

ip address 172.25.1.1 255.255.255.128

no ip redirects

ip pim dense-mode

!

interface GigabitEthernet0/1.241

encapsulation dot1Q 241

ip address 172.20.32.1 255.255.255.0

no ip redirects

ip pim dense-mode

!

Switch Configuration

interface FastEthernet0/1

switchport mode trunk

no ip address

speed 100

!

interface FastEthernet0/13

switchport access vlan 17

no ip address

duplex full

speed 100

!

interface FastEthernet0/15

switchport access vlan 241

no ip address

duplex full

speed 100

!

Switch Log

Version - cisco WS-C2950G-48-EI

SWITCH#show ip igmp snooping vlan 17

vlan 17

----------

IGMP snooping is globally enabled

IGMP snooping is enabled on this Vlan

IGMP snooping immediate-leave is disabled on this Vlan

IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan

IGMP snooping is running in IGMP_ONLY mode on this Vlan

MDC3-68-DC-SPARE#show ip igmp snooping vlan 241

vlan 241

----------

IGMP snooping is globally enabled

IGMP snooping is enabled on this Vlan

IGMP snooping immediate-leave is disabled on this Vlan

IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan

IGMP snooping is running in IGMP_ONLY mode on this Vlan

SWITCH#sh mac-address-table multicast

Vlan    Mac Address       Type       Ports

----    -----------       ----       -----

  17    0100.5e00.0128    IGMP       Fa0/1

  17    0100.5e64.6464    IGMP       Fa0/1, Fa0/13

  17    0100.5e7f.fffa    IGMP       Fa0/1, Fa0/13

241    0100.5e64.6464    IGMP       Fa0/1

241    0100.5e7f.0203    IGMP       Fa0/1, Fa0/15

Router Log

Version - Cisco 2821 Version 12.4(15)T9

ROUTER#show ip igmp groups

IGMP Connected Group Membership

Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted

239.255.2.3      GigabitEthernet0/1.241   03:03:55  00:02:13  172.20.32.62

239.100.100.100  GigabitEthernet0/1.17    01:18:06  00:02:07  172.25.1.8

224.0.1.40       GigabitEthernet0/1.17    04:34:57  00:02:04  172.25.1.1

ROUTER#sh ip mroute 239.100.100.100

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.100.100.100), 01:18:48/00:02:29, RP 0.0.0.0, flags: DC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/1.17, Forward/Dense, 01:18:48/00:00:00

ROUTER#show ip igmp interface

GigabitEthernet0/1.17 is up, line protocol is up

  Internet address is 172.25.1.1/25

  IGMP is enabled on interface

  Current IGMP host version is 2

  Current IGMP router version is 2

  IGMP query interval is 60 seconds

  IGMP querier timeout is 120 seconds

  IGMP max query response time is 10 seconds

  Last member query count is 2

  Last member query response interval is 1000 ms

  Inbound IGMP access group is not set

  IGMP activity: 22 joins, 19 leaves

  Multicast routing is enabled on interface

  Multicast TTL threshold is 0

  Multicast designated router (DR) is 172.25.1.1 (this system)

  IGMP querying router is 172.25.1.1 (this system)

  Multicast groups joined by this system (number of users):

      224.0.1.40(1)

GigabitEthernet0/1.241 is up, line protocol is up

  Internet address is 172.20.32.1/24

  IGMP is enabled on interface

  Current IGMP host version is 2

  Current IGMP router version is 2

  IGMP query interval is 60 seconds

  IGMP querier timeout is 120 seconds

  IGMP max query response time is 10 seconds

  Last member query count is 2

  Last member query response interval is 1000 ms

  Inbound IGMP access group is not set

  IGMP activity: 10 joins, 9 leaves

  Multicast routing is enabled on interface

  Multicast TTL threshold is 0

  Multicast designated router (DR) is 172.20.32.1 (this system)

  IGMP querying router is 172.20.32.1 (this system)

  No multicast groups joined by this system

Message was edited by: NSG_POLARIS

Jon Marshall Mon, 02/01/2010 - 03:42

NSG_POLARIS wrote:

Dear All,

I am trying multicast video stream in my network but it is not working between Vlans. But its works fine in the same vlan.

Using VLC for video straming. Router, switch and pcs are connected as given in the below link.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a00800b0871.shtml

Router - Cisco 2821

Swicth - Cisco 2950

Pls guide me to make this works.

Regards,

Gopi

Gopi

Things to check

1) You have enabled "ip multicast-routing" on the 2821 router

2) Under each L3 interface on the router you have enabled PIM -

    i) if pim-dense mode that is all you need

   ii) if pim sparse-mode have you configured the RP manually or have you configured auto-rp

3) VLC - when you stream the data make sure you set the TTL to be more than 1. For each L3 hop add 1 to the ttl

4) optionally, you have enabled IGMP snooping on the 2950 switch

Jon

NSG_POLARIS Mon, 02/01/2010 - 04:34

Pls check the config given in the previous post and advice me.

Regards,

Gopi

Correct Answer
Mohamed Sobair Mon, 02/01/2010 - 06:38

Hi,

The router is detecting IGMP hosts to join group 239.100.100.100.

and you have enable multiccast routing + pim on all router interfaces. what is the ttl value used by VLC to stream the multicast?

The (Sh ip mroute) on the router doesnt provide the desired result?  So there is a problem.

Try to ping the group from the server , and do (sh ip mroute) on the router. statically join group 239.100.100.100 on the router interface

pls post back the result..

HTH

Mohamed

NSG_POLARIS Tue, 02/02/2010 - 03:32

Thanks ! It is working now in my test bench.

The issue was with vlc player. It was not accepting the ttl value given through gui mode. It is accepting the ttl value only in the cmd mode.

Regards,

Gopi

Actions

This Discussion