4510R-E and TwinGig Modules

Answered Question
Feb 1st, 2010
User Badges:

Hi,


I have a couple of 4510e switches with dual SUP 6-E modules in slots 5 and 6, both running 12.2(52)SG.

In each of the 4 10gig slots I have the TwinGig converters, however only the first of the modules is showing up as active...


Switch#sh hw-module module 5 port-group
Module Port-group Active                         Inactive
-------------------------------------------------------------
   5        1     Gi5/3-4                        Te5/1                        
   5        2                                    Te5/2,Gi5/5-6                

Switch#sh hw-module module 6 port-group
Module Port-group Active                         Inactive
-------------------------------------------------------------
   6        1     Gi6/3-4                        Te6/1                        
   6        2                                    Te6/2,Gi6/5-6                

Switch#sh int status | incl [5|6]/
Te5/1                        inactive     1            full    10G No X2
Te5/2                        inactive     1            full    10G No X2
Gi5/3                        connected    trunk        full   1000 1000BaseSX
Gi5/4                        notconnect   1            full   1000 No Gbic
Gi5/5                        inactive     trunk        full   1000 1000BaseSX
Gi5/6                        inactive     1            full   1000 No Gbic
Te6/1                        inactive     1            full    10G No X2
Te6/2                        inactive     1            full    10G No X2
Gi6/3                        connected    trunk        full   1000 1000BaseSX
Gi6/4                        notconnect   1            full   1000 No Gbic
Gi6/5                        inactive     trunk        full   1000 1000BaseSX
Gi6/6                        inactive     1            full   1000 No Gbic


I issued the commands


hw-module module 5 port-group 1 select gigabitethernet
hw-module module 5 port-group 2 select gigabitethernet
hw-module module 6 port-group 1 select gigabitethernet
hw-module module 6 port-group 2 select gigabitethernet


in order to use the TwinGig modules, but like I said, only the first module is functioning as desired.  Am I missing some commands to active the other two Gig ports?


Here are the running configs for all relevant ports...I'd like to use Gig5/3, Gig5/5, Gig6/3 and Gig 6/5 in a Port-Channel.


interface TenGigabitEthernet5/1
!
interface TenGigabitEthernet5/2
!
interface GigabitEthernet5/3
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control action trap
channel-group 1 mode on
!
interface GigabitEthernet5/4
!
interface GigabitEthernet5/5
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control action trap
channel-group 1 mode on
!
interface GigabitEthernet5/6
!
interface TenGigabitEthernet6/1
!        
interface TenGigabitEthernet6/2
!
interface GigabitEthernet6/3
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control action trap
channel-group 1 mode on
!
interface GigabitEthernet6/4
!
interface GigabitEthernet6/5
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control action trap
channel-group 1 mode on
!
interface GigabitEthernet6/6
!
interface Port-channel1
description ** to Core Switches **
switchport
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control action trap
end



What am I doing wrong??

Correct Answer by chris.macleod about 7 years 3 months ago

Have a look at the Supervisor Engine Redundancy Guidelines and Restrictions section and see what you think.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
chris.macleod Mon, 02/01/2010 - 10:36
User Badges:

Hi,


I believe this is a limitation when using redundancy modes rpr or sso.



Thanks

Chris

Correct Answer
chris.macleod Mon, 02/01/2010 - 10:55
User Badges:

Have a look at the Supervisor Engine Redundancy Guidelines and Restrictions section and see what you think.

Attachment: 
rrfield Mon, 02/01/2010 - 11:11
User Badges:

  When you select 10-Gigabit Ethernet uplinks on WS-X4516-10GE and WS-X4013+10GE

  Supervisor Engines in RPR or SSO mode, only TenGigabitEthernet 1/1 and 2/1 interfaces are
  available. Similarly, when you select Gigabit Ethernet uplinks, only GigabitEthernet 1/3, 1/4, 2/3,
  and 2/4 interfaces are available. When you select to use both uplinks concurrently,
  TenGigabitEthernet 1/1 and 2/1 interfaces and GigabitEthernet 1/3, 1/4, 2/3, and 2/4 interfaces are
  available.



Yup, that is the exact behavior I'm seeing.  Thank you very much!

Actions

This Discussion