Problems with UC520 after failed SW-Upgrade

Unanswered Question
Feb 1st, 2010
User Badges:

Dear community,

after three days of testing and scratching my head I do admit I have a problem...

I tried to upgrade my UC520 (basic with 8 Userlicense) to a new software version (contents of ZIP-File UC520-8.0.0.zip, that is, version 8.0 and cue 7.1.3). I tried to do that with cca version 2.1(1). The installation failed...

Failure code in CCA was

- IOS went fine

- phone loads went fine

- CUE failed because of a missing license file (what file???)


Now, after restartíng the device I noticed that the densly populated flash: store is now quite empty:

#dir
Directory of flash:/


    1  -rw-         720  Jan 29 2010 17:46:28 -01:00  vlan.dat
    2  -rw-    37988016  Jan 29 2010 16:34:04 -01:00  uc500-advipservicesk9-mz.150-1.XA
    3  drw-           0  Jan 29 2010 16:34:18 -01:00  phones
   23  drw-           0  Jan 29 2010 16:35:54 -01:00  Desktops
   42  drw-           0  Jan 29 2010 16:36:04 -01:00  autoattendant
   46  drw-           0  Jan 29 2010 16:36:06 -01:00  bacdprompts
   57  drw-           0  Jan 29 2010 16:36:14 -01:00  cca
   61  drw-           0  Jan 29 2010 16:36:16 -01:00  gui
   83  drw-           0  Jan 29 2010 16:36:30 -01:00  media
   86  drw-           0  Jan 29 2010 16:36:36 -01:00  ringtones
  120  drw-           0  Jan 29 2010 16:36:50 -01:00  sn


128184320 bytes total (67821568 bytes free)


But, phones do work to some extent. No problems with phoning between the phones BUT the 7942 does not have a ring tone, it stays silent (only displaying incoming call). When restarting that phone I do not see any attempt to load the Ringtone.xml file nor any ringtones.


Also, when trying to access the voicemail (set onto 999 here) I only receive a busy signal...

The service engine is running:

ser i 0/0 status
Service Module is Cisco Integrated-Service-Engine0/0
Service Module supports session via TTY line 2
Service Module is in Steady state
Service Module heartbeat-reset is enabled
Getting status from the Service Module, please wait..


Cisco Unity Express 7.1.3
CUE is on UC500UC500


But in the servicemodule the command "show software version" is somewhat less that expected:

sh software vers
Cisco Unity Express version (7.1.3)
Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2009 by Cisco Systems, Inc.


Components:


- CUE Voicemail Language Support version  7.1.3



What do I need to do to reenable everything? Reinstall? Then how?


I can post any tech-support files, I can completely reset the device since it is not in production at the moment


Thanks


Mathias

who is R&S CCIE and has nearly no clue about CUE/CME

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Mon, 02/01/2010 - 16:27
User Badges:
  • Gold, 750 points or more

I would try doing the upgrade again through CCA to see if you can get CUE upgraded.  If that does not work, I would recommend opening a case with TAC to see if you can get this issue resolved.

Steven DiStefano Tue, 02/02/2010 - 13:03
User Badges:
  • Blue, 1500 points or more

Regarding the flash:    , do a

dir /recursive

and see that the directory structure is implemented (CCA does this when you check that box about formating flash),  and sub directories should have data.....

gaertnerm Wed, 02/03/2010 - 12:04
User Badges:

Hello again,

the idea of reinstalling did the trick, but only after updating cca to the newest version. It still failed, but now only in the stage of restoring the backuped configuration in cue. This was no problem at all (here).

As for the flash:,

yes, the flash is not empty, but in the previous version a lot of files resided in the root-directory, i.e. the factory-reset configuration or some app-files.

Now everything is in subdirectory or missing (is it? no idea at the moment) completely.


One thing to the "silent" phone. I had to reconfig the corresponding "ephone" to have a ringtone again. Just "no ephone 13", "ephone 13" and the same subcommands.

A bit strange but I do not ask :-)


Mathias

Actions

This Discussion