SDLC -> DLSW -> EE(SNASW) question

Unanswered Question
Feb 1st, 2010
User Badges:

I have very little background knowledge of DLSW or SNASwitching, but here goes...


I am currently trying to migrate an existing connection from SDLC -> DLSW ->token ring mainframe connection to SDLC -> DLSW -> SNASW EE.  My EE connection from the cisco router to hte mainframe is up and active, but I am unable to get the DLSW connection to work.  I have been able to get the Peers to CONNECT, but I do not have any DLSW circuits. 


Remote Router


!
dlsw local-peer peer-id 192.168.105.84
dlsw remote-peer 0 tcp 10.248.3.36
dlsw remote-peer 0 tcp 192.168.105.46
dlsw remote-peer 0 tcp 192.168.105.47
!
interface Ethernet0/0
ip address 192.168.105.84 255.255.255.0
!
interface Serial0/0
no ip address
shutdown
!
interface BRI0/0
no ip address
shutdown
!
interface Serial1/0
description MPSM - MPS SDLC connection to MPS9 gateway
bandwidth 19200
no ip address
encapsulation sdlc
no keepalive
sdlc role primary
sdlc vmac 4534.0000.0900
sdlc address C1
sdlc xid C1 05310170
sdlc partner 4800.0000.0000 C1
sdlc dlsw C1
!
interface Serial1/1
description MPSM MT80MPS7 - IP80GG73
bandwidth 19200
no ip address
encapsulation sdlc
no keepalive
sdlc role primary
sdlc vmac 4534.0000.0700
sdlc address C1
sdlc xid C1 05310172
sdlc partner 4800.0000.0000 C1
sdlc dlsw C1
!
interface Serial1/2
description MPSM MT80MPS5 - IP80GG53
bandwidth 19200
no ip address
encapsulation sdlc
no keepalive
sdlc role primary
sdlc vmac 4534.0000.0500
sdlc address C1
sdlc xid C1 05310174
sdlc partner 4800.0000.0000 C1
sdlc dlsw C1
!

RTGRAMIHQMPSM01#sho dlsw peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
TCP 10.248.3.36     CONNECT      58648     59193  conf      0    0   0     2w6d
TCP 192.168.105.46  CONNECT    1085642   1212360  conf      0    2   0     2w6d
TCP 192.168.105.47  CONNECT      58492     58492  conf      0    0   0     2w6d
Total number of connected peers: 3
Total number of connections:     3

RTGRAMIHQMPSM01#sho dlsw circ
Index           local addr(lsap)    remote addr(dsap)  state          uptime
1929380244      4534.0000.05c1(04)  4800.0000.0000(04) CONNECTED          2w6d
2969567635      4534.0000.07c1(04)  4800.0000.0000(04) CONNECTED          2w6d
Total number of circuits connected: 2


Data Center Router

source-bridge ring-group 336
!
dlsw local-peer peer-id 10.248.3.36
dlsw remote-peer 0 tcp 192.168.105.84
dlsw remote-peer 0 tcp 192.168.105.85
!
!
!
interface Loopback0
ip address 10.210.136.65 255.255.255.255
!
interface GigabitEthernet0/1
description VLAN526 to XWGRAMIDCFPIP01
ip address 10.248.3.36 255.255.255.248
duplex full
speed 100
media-type rj45
negotiation auto
!
interface FastEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
description VLAN529 to XWGRAMIDCFPIP02
ip address 10.248.3.44 255.255.255.248
duplex full
speed 100
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
snasw pdlog information
snasw dlctrace buffer-size 10000
snasw cpname NETMPS.GRSNAS01
snasw dlus NETMPS.XD81
snasw port SNSWPORT hpr-ip GigabitEthernet0/1
snasw port DLSWPORT vdlc 336 mac 4800.0000.0000 conntype nohpr
snasw link SW01XD81 port SNSWPORT ip-dest 204.90.2.14
!

RTGRAMIDCSNAS01#sho dlsw peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
TCP 192.168.105.84  CONNECT      58652     58649  conf      0    0   0     2w6d
TCP 192.168.105.85  CONNECT      58578     58578  conf      0    0   0     2w6d
Total number of connected peers: 2
Total number of connections:     2

RTGRAMIDCSNAS01#sho dlsw circ

RTGRAMIDCSNAS01#



Like I said, I have little background knowledge about this connectivity.  If there is additional information that I could provide, please let me know.  Any help would be greatly appreciated.


Thanks,

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion