<Protect_IVR_FactoryReset> does not work on SPA525G

Unanswered Question
Feb 1st, 2010
User Badges:

Does not protect LCD display for factory reset


Firmware is 525G , works on 504 . 502, 942,962


<Protect_IVR_FactoryReset ua="na">Yes</Protect_IVR_FactoryReset>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Mon, 02/01/2010 - 09:33
User Badges:
  • Gold, 750 points or more

What firmware are you running on the 525? 

CSCtd35385 spa525: factory reset is allowed with admin pw and protect IVRfactoryres


This should be fixed in 7.4.3.

FlyingDoctor_2 Mon, 02/01/2010 - 09:48
User Badges:

Sorry Thought I had put firmware version


is 7.4.3


problem is that admin password not set via



set password on Web and factory reset prompts for password as should


FYI  - some LDAP config fields are also broken on the 525 - could be related

Steven Smith Mon, 02/01/2010 - 10:01
User Badges:
  • Gold, 750 points or more

Admin password is required for this Protect_IVR_FactoryReset to work.


Which LDAP fields are you saying do not work?

FlyingDoctor_2 Mon, 02/01/2010 - 10:28
User Badges:

I know the admin password is required


What I am saying is that is not being set by the xml

Steven Smith Mon, 02/01/2010 - 13:19
User Badges:
  • Gold, 750 points or more

Can you send me the XML you are using?

FlyingDoctor_2 Tue, 02/02/2010 - 00:07
User Badges:

Our  XML is generated dynamically so there is no file, I would not post our config on a public forum anyway


This is the bit you need - I have changed the passowrd


This works on 941,942 962, 504 and 502



......xxxxxxxxxYes........

FlyingDoctor_2 Tue, 02/02/2010 - 06:48
User Badges:

it is another 525 gratuitous field  name change  -> is now (only on 525)   Admin_Password

nseto Tue, 02/02/2010 - 09:12
User Badges:
  • Silver, 250 points or more

What is meant by xml generated dynamically?  The xml is usually made by using the spc tool.

FlyingDoctor_2 Tue, 02/02/2010 - 15:27
User Badges:

we have many 1000's  of phones - we generate the xml on the fly when requested by the device


The issue here is not how the XML is generated , but inconsistences in the field names between the 525G and other devices

nseto Wed, 02/03/2010 - 10:28
User Badges:
  • Silver, 250 points or more

Please go into more details regarding inconsistent info between the products, I'll be able to write a bug report based on this info.

FlyingDoctor_2 Mon, 02/08/2010 - 09:05
User Badges:

The list is growing


  • Programmable_Softkey_Enable  only on 525


  • Admin_Password different


  • Several LDAP Directory fields different
nseto Mon, 02/08/2010 - 10:36
User Badges:
  • Silver, 250 points or more

Ok, thanks.  I'll write up a bug regarding these field name issues.