Cisco 857w ADSL configuration

Unanswered Question
Feb 1st, 2010

Help me in configuring of cisco adsl 857w for DHCP.

Can anyone send me the sample for this configuration.

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 02/01/2010 - 12:52

Hello Er,

do you want the router to behave as a DHCP server or to be a DHCP client on one of its own interfaces?

a) client

  int fas0/0

ip address dhcp

b) server router acting as DHCP server for one or more subnets that are directly connected

see this example:

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Tabella normale"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

ip dhcp excluded-address 10.110.224.129 10.110.224.132

ip dhcp excluded-address 10.110.224.145

!

ip dhcp pool DATA

   network 10.110.224.128 255.255.255.240

   default-router 10.110.224.129

   dns-server 10.98.112.32 10.55.0.32

   netbios-name-server 10.52.64.37 10.24.128.151

   lease 0 1

!

ip dhcp pool VOICE

   network 10.110.224.144 255.255.255.248

   default-router 10.110.224.145

   dns-server 10.98.112.32 10.55.0.32

   netbios-name-server 10.52.64.37 10.24.128.151

   option 150 ip 10.98.67.5 10.55.61.4

   lease 0 1

first pool is for PCs, second pool is for Cisco IP phones option 150 specifies TFTP servers

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Tabella normale"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

interface FastEthernet0/0

no ip address

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0/0.10

description VLAN DATA

encapsulation dot1Q 10

ip address 10.110.224.129 255.255.255.240

no ip redirects

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0/0.20

description VLAN VOICE

encapsulation dot1Q 20

ip address 10.110.224.145 255.255.255.248

no ip redirects

Hope to help

Giuseppe

Actions

This Discussion