Problem dialing from Multiple Ephones DN's

Answered Question
Feb 1st, 2010

Hello All,

            I have a CME router connected to a SIP trunk but, would like to use any of my internal EXT to dial out over the SIP trunk. I only have one 2131114473 phone Number. How do I allow any phone from with an internal EXT to dial out over the SIP trunk? I fully understand I only and dial out with one phone at a time but when at home would like to answer the phone for incoming calls no matter what part the house I am in.

SIPGATEWAY#sh run
Building configuration

Current configuration : 4894 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SIPGATEWAY
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.5.1 192.168.5.10
!
ip dhcp pool ITS
   network 192.168.5.0 255.255.255.0
   option 150 ip 192.168.5.1
   default-router 192.168.5.1
!
!
ip host sip.littleman.com 22.135.32.221
ip host littleman.com 22.135.32.221
!
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to sip
!
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-any AutoQoS-VoIP-Remark
match ip dscp ef
match ip dscp cs3
match ip dscp af31
class-map match-any AutoQoS-VoIP-Control-UnTrust
match access-group name AutoQoS-VoIP-Control
class-map match-any AutoQoS-VoIP-RTP-UnTrust
match protocol rtp audio
match access-group name AutoQoS-VoIP-RTCP
!
!
policy-map AutoQoS-Policy-UnTrust
class AutoQoS-VoIP-RTP-UnTrust
  priority percent 70
  set dscp ef
class AutoQoS-VoIP-Control-UnTrust
  bandwidth percent 5
  set dscp af31
class AutoQoS-VoIP-Remark
  set dscp default
class class-default
  fair-queue
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
auto qos voip
service-policy output AutoQoS-Policy-UnTrust
!
interface Serial0/0
no ip address
no fair-queue
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
!
ip route 10.3.3.0 255.255.255.0 192.168.2.50
!
!
ip http server
no ip http secure-server
!
ip access-list extended AutoQoS-VoIP-Control
permit tcp any any eq 1720
permit tcp any any range 11000 11999
permit udp any any eq 2427
permit tcp any any eq 2428
permit tcp any any range 2000 2002
permit udp any any eq 1719
permit udp any any eq 5060
ip access-list extended AutoQoS-VoIP-RTCP
permit udp any any range 16384 32767
!
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.1081.1083 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
!
!
!
!
!
!
dial-peer voice 2 voip
destination-pattern ..........
voice-class codec 1
voice-class sip url sip
session protocol sipv2
session target dns:sip.littleman.com
dtmf-relay rtp-nte
no vad
!
dial-peer voice 3 voip
description Long Distance Domestic
destination-pattern 1..........
voice-class codec 1
voice-class sip url sip
session protocol sipv2
session target dns:sip.littleman.com
dtmf-relay rtp-nte
no vad
!
dial-peer voice 4 voip
description Long Distance International
destination-pattern 9011T
voice-class codec 1
voice-class sip url sip
session protocol sipv2
session target dns:sip.littleman.com
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1 voip
description Incoming Call from SIP Trunk
destination-pattern 9011T
voice-class codec 1
session protocol sipv2
session target dns:sip.littleman.com
incoming called-number 2131114473
dtmf-relay rtp-nte
no vad
!
dial-peer voice 5 voip
description **Emergency Outgoing Call to SIP Trunk**
destination-pattern 911
voice-class codec 1
session protocol sipv2
session target dns:sip.littleman.com
dtmf-relay rtp-nte
no vad
!
sip-ua
authentication username 2131114473 password 15182A2F372F1C123
no remote-party-id
retry invite 2
retry register 10
registrar dns:sip.littleman.com expires 3600
sip-server dns:sip.littleman.com
!
!
!
!
telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.5.1 port 2000
auto assign 1 to 10
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 4 gain -6
moh music-on-hold.au
multicast moh 239.10.16.4 port 2000
transfer-system full-consult
!
!
ephone-dn  1  dual-line
number 5001 no-reg primary
name
!
!
ephone-dn  2  dual-line
number 2131114473
!
!
ephone-dn  3  dual-line
number 5003 no-reg both
!
!
ephone-dn  4  dual-line
number 5004 no-reg both
!
!
ephone-dn  5  dual-line
number 5005 no-reg both
!
!
ephone-dn  6  dual-line
number 5006 no-reg both
!
!
ephone-dn  7  dual-line
number 5007 no-reg both
!
!
ephone-dn  8  dual-line
number 5008 no-reg both
!
!
ephone-dn  9  dual-line
number 5009 no-reg both
!
!
ephone-dn  10  dual-line
number 5010 no-reg both
!
!
ephone  1
description
mac-address 000F.34EC.C959
type 7940
button  1:1
!
!
!
ephone  2
!
!
!
ephone  3
mac-address 0012.179A.0E28
type CIPC
button  1:2
!
!
!
ephone  4
!
!
!
ephone  5
!
!
!
ephone  6
!
!
!
ephone  7
!
!
!
ephone  8
!
!
!
ephone  9
!
!
!
ephone  10
!
!
!
line con 0
line aux 0
line vty 0 4
no login
!
!
end

SIPGATEWAY#sh sip-ua reg stat
Line          peer           expires(sec)  registered
============  =============  ============  ===========
2131114473    20002            18            yes

I have this problem too.
0 votes
Correct Answer by Brandon Buffin about 6 years 11 months ago

Yes, this should allow you to make and receive calls via this number from any phone.

Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Tue, 02/02/2010 - 09:10

One option is to overlay the SIP registered DN on each phone such as:

ephone  1
description
mac-address 000F.34EC.C959
type 7940
button  1o2,1

ephone  3
mac-address 0012.179A.0E28
type CIPC
button  1:2,3

Hope this helps.

Brandon

Charlie Mayes Tue, 02/02/2010 - 11:07

Are you saying all I have to do is assign the same number from the provider on one of the buttons on each phone?

Correct Answer
Brandon Buffin Tue, 02/02/2010 - 12:03

Yes, this should allow you to make and receive calls via this number from any phone.

Brandon

Actions

This Discussion