Cisco 877 ADSL2+ Fast Sync Slow Throughput

Unanswered Question
Feb 1st, 2010


I have 2 load balanced Cisco 877 routers each running  IOS c870-advipservicesk9-mz.124-22.T.bin and the latest modem firmware.(I have tried several makes no difference). The problem is that even though both lines are syncing at 16MB+ I can only achieve a 1.5mb download speed(not being throttled anywhere local). Can you spot anything in these print outs im missing? Uploads seem to be fine. I noticed on the first sh there is "output drops" not sure what they might be?

Any ideas would be appreciated!



yourname#sh interface atm0
ATM0 is up, line protocol is up
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 886 Kbit/sec, DLY 410 usec,
     reliability 255/255, txload 124/255, rxload 175/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  10 maximum active VCs, 1024 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 5534
  Queueing strategy: Per VC Queueing
  5 minute input rate 2086000 bits/sec, 350 packets/sec
  5 minute output rate 433000 bits/sec, 253 packets/sec
     831098 packets input, 544960024 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 5 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     692734 packets output, 140056671 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

yourname#show dsl interface
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:     0x03                            0x2
Chip Vendor ID:  'STMI'                          'IFTN'
Chip Vendor Specific:  0x0000                    0x71B9
Chip Vendor Country:   0x0F                      0xB5
Modem Vendor ID: 'CSCO'                          '    '
Modem Vendor Specific: 0x0000                    0x0000
Modem Vendor Country:  0xB5                      0x00
Serial Number Near:    FCZ113120PS
Serial Number Far:
Modem VerChip ID:        C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   96%                             99%
Noise Margin:     5.0 dB                         16.5 dB
Output Power:    20.0 dBm                        12.5 dBm
Attenuation:     28.5 dB                         13.0 dB
FEC ES Errors:    0                               0
ES Errors:        1                               0
SES Errors:       1                               0
LOSES Errors:     1                               2
UES Errors:       0                              109
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0xAB
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      4154 (0 spurious)
PHY Access Err:  0
Activations:     1
LED Status:      ON
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR_4.0.018.bin
Operation FW:    AMR-E-4.0.018.bin
FW Source:       external
FW Version:      4.0.18

                 DS Channel1      DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            17443             0               886
Cells:                    0          5143184             0           2940045
Reed-Solomon EC:          0              166             0                 0
CRC Errors:               0                0             0                51
Header Errors:            0                0             0                10
Total BER:                0E-0           0E-0
Leakage Average BER:      0E-0           0E-0
Interleave Delay:         0               37             0                 0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
johnelliot6 Mon, 02/01/2010 - 21:35


Have you checked duplex on LAN Int?

Was that sh int atm taken while downloading+uploading?(tx and rx loads are quite high)

sterion75 Mon, 02/01/2010 - 23:35

Yes lan is running at 100mbps full duplex

These routers were actively being used but as I say 1.5mbps so I don't understand why the rx was that high as it was only downloading at 1/16 of it's sync speed, Im assuming your referring to Capacity Used:   96%                             99% ?

I think that figure has always been very high even under little load

any idea?


johnelliot6 Tue, 02/02/2010 - 00:06

No, rx and tx under your sh int atm.


Here's an 857 w/ ads2+ doing nothing:

#sh int atM 0
ATM0 is up, line protocol is up
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 1017 Kbit/sec, DLY 360 usec,
     reliability 255/255, txload 1/255, rxload 1/255

And now downloading file @ ~950K/sec

#sh int atM 0
ATM0 is up, line protocol is up
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 1017 Kbit/sec, DLY 360 usec,
     reliability 255/255, txload 9/255, rxload 156/255

You haven't set a low rate under atm pvc?(i.e. ubr etc)

Oh - And your not trying to test ingress/egress simultaneously on an adsl service right?

sterion75 Tue, 02/02/2010 - 01:41

Don't think so. Here is our config. It's a little messy but always did the job on normal adsl

To test I have been using, bbmax and other similar sites. Their normally quite reliable

Also you can tell when its slow as u can only download at very very slow speeds

no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
hostname Router1
logging buffered 51200 debugging
logging console critical
enable secret ******

username admin privilege 15 secret 5 ******

no aaa new-model
resource policy
clock timezone London 0
clock summer-time London date Mar 30 2003 1:00 Oct 26 2003 2:00
ip subnet-zero
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address
ip dhcp pool sdm-pool1
   import all
ip tcp synwait-time 10
no ip bootp server
ip domain name
ip name-server
ip name-server
ip ssh time-out 60
ip ssh authentication-retries 2
crypto pki trustpoint TP-self-signed-633710060
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-633710060
revocation-check none
rsakeypair TP-self-signed-633710060
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
no snmp trap link-status
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
interface FastEthernet0
interface FastEthernet1
interface FastEthernet2
interface FastEthernet3
interface Vlan1
ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
mtu 1483 <--- this appears even if I dont set it
ppp authentication chap callin
ppp chap hostname xxxxxx

ppp chap password xxxxx

ip classless
ip route Dialer0
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 5000 interface Dialer0 5000
ip nat inside source static tcp 3389 interface Dialer0 3389
ip nat inside source static tcp 8088 interface Dialer0 8088
ip nat inside source static tcp 2022 interface Dialer0 2022
ip access-list extended nat3
remark SDM_ACL Category=2
permit ip any
ip access-list extended rule2
remark SDM_ACL Category=2
permit ip any
logging trap debugging
access-list 1 permit
access-list 1 permit
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit
access-list 1 permit
dialer-list 1 protocol ip permit
no cdp run
line con 0
password sxxxxx

no modem enable
stopbits 1
line aux 0
stopbits 1
line vty 0 4
access-class 1 in
exec-timeout 0 0
password sonix

johnelliot6 Tue, 02/02/2010 - 01:47

Request download/upload server from your ISP to prove service - Also confirm with ISP what profile is on line.

sterion75 Tue, 02/02/2010 - 02:07

Have spoken to BT they won't look at this till Friday as were still within the 10 day sync period(which personally I don't think makes a bit of difference).

I think the line speed is being throttled between 5pm and midnight(when I was testing it). I tried this morning and got burst speeds of 11mb on each line(still not the full speed indicated by the sync speed though)


sterion75 Tue, 02/02/2010 - 13:08

Someone has mentioned using

clock rate aal5 downspeed+1000

clock rate aal2 upspeed+200

However on configuring ATM0 clock rate fails to add at clock

On Dialer0 it fails to add at aal5

Any ideas on this?

fieldr Fri, 05/20/2011 - 08:54

This is a very similar problem to one we are experiencing...

Has anyone resolved the problem or moved it forward?

bostonacuk Fri, 05/20/2011 - 11:21

This was the ISP throttling due to over usage

Try running a standard modem first to be sure. We do have another cisco unit running slow but this is modem firmware I believe we have to upgrade to 15.1.4(m) but havent had chance yet


fieldr Mon, 05/23/2011 - 08:29

Thanks, for the update.

Our problem is only Cisco specific, if we use a Netgear we get near the full through put so I don't see how it could be the ISP...

Back to the drawing board!

speculatrix Fri, 02/10/2012 - 03:16

I have a similar problem with an 877W on an ADSL line here in the UK, but somewhat more puzzling.

the line sync is just over 4M, and for short transfers  I can achieve close to 3.8Mb/s, but after a few megabytes it slows down  and eventually to a crawl, worse than dial-up modem speed!

I  have substituted a spare domestic-class Zyxel modem/router and have no  problems at all, I was able to download a multi-hundred-megabyte ISO and  maintain a steady 3.3MB/s all the time.

There's no traffic shaping defined on the Cisco. I  have been wondering if it's faulty as it locks up from time to time and  the other day didn't come back after a power-on reset, connecting serial  console showed it had trashed its config and I had to restore from a  kiwi-cattools backup!

We have another 877W on a different ADSL line, it's  running the same IOS and same modem firmware and has been solid. I am  wondering about invoking the cisco maintenance contract on the dodgy  877W.

#show ver


ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE


System image file is "flash:c870-advipservicesk9-mz.124-24.T6.bin"


Cisco 877W (MPC8272) processor (revision 0x400) with  118784K/12288K bytes of  memory.                                                       

Processor board ID xxxxxxxxx                                                                                                              

MPC8272 CPU Rev: Part Number 0xC, Mask Number  0x10                                                                                         

4 FastEthernet interfaces

1 ATM interface

1 802.11 Radio

128K bytes of non-volatile configuration memory.

28672K bytes of processor board System flash (Intel Strataflash)

#show atm inter atm0

Interface ATM0:

AAL enabled:  AAL5   AAL2, Maximum VCs: 10, Current VCCs: 1

VCIs per VPI: 1024,

Max. Datagram Size: 4528

PLIM Type: ADSL - 768Kbps Upstream, DMT, TX clocking: LINE

483981 input, 85361 output, 29959207 IN fast, 45534484 OUT fast

Avail bw = 768

Config. is ACTIVE


This Discussion