4507 upgrade issue

Unanswered Question
Feb 2nd, 2010

A colleague tried to upgrade a 4507 recently, and got the following error:

loadprog: cannot read file's "ELF  section" header

boot: can not load  "bootflash:cat4500-entservicesk9-mz.122-53.SG1.bin"

Modules are:

Mod Ports Card  Type                              Model              Serial  No.

---+-----+--------------------------------------+------------------+-----------

1     6  Sup V-10GE 10GE (X2),  1000BaseX (SFP)  WS-X4516-10GE     

2     6  Sup V-10GE 10GE (X2),  1000BaseX (SFP)  WS-X4516-10GE    

3    48  10/100/1000BaseT (RJ45)V,  Cisco/IEEE   WS-X4548-GB-RJ45V 

4    48  10/100/1000BaseT (RJ45)V,  Cisco/IEEE   WS-X4548-GB-RJ45V 

5    48  10/100/1000BaseT (RJ45)V,  Cisco/IEEE   WS-X4548-GB-RJ45V 

6    48  10/100/1000BaseT (RJ45)V,  Cisco/IEEE   WS-X4548-GB-RJ45V 

A check suggests this version *should* be valid for the hardware.

Any idea what the error means? is this simply a file corruption error, might we have an issue with the flash, or is this something significant?

Thanks,

Paul.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Tue, 02/02/2010 - 06:46

Hi Paul

Can you try adding another IOS on the bootflash, and try booting from that ? force booting from the second IOS through the boot statements (just to isolate IOS issues).. So what happens after this error occurs ? Does your switch goes to ROMMON and you boot again from ROMMON ?

Raj

paul.matthews Thu, 02/11/2010 - 00:43

There has been a litle interest in this. Unfortunately I was not present when the initial attempt was made, so I do not have a full picture of what hapenned.

As a minor update, I downloaded the same IOS and got my colleague to send me the exact file he was using. Running MD5 Checksums they matched, and matched the checksum on CCO, so the basic file was OK.

I downloaded it to my lab 4500, to see ehat hapenned there. There are a couple of little differences between mine and the live switch - mine is a standard SUP-V, live has 10GE, live is also redundant sup, and mine is only a 4503. So there are some differences, but nothing hugely significant.

It booted fine on mine.

He is going to have another try this weekend. I have a suspicion it may just have been "one of those things" if all goes OK, otherwise I am suspicious of the flash on the sup.

Brent Rockburn Tue, 02/02/2010 - 08:10

I'm about to try to upgrade my 4507 to "cat4500e-entservicesk9-mz.122-53.SG1.bin" from "cat4500e-entservicesk9-mz.122-50.SG.bin"

So I'm interested in what the issue was here ..

right now I have it setup so that the old IOS is still on the switch and ready to be the back up.

like this.

boot system flash bootflash:cat4500e-entservicesk9-mz.122-53.SG1.bin
boot system flash bootflash:cat4500e-entservicesk9-mz.122-50.SG.bin

Does anyone know what the problem was?

Sorry for highjacking your thread...

Brent

Actions

This Discussion