525G dictoniary localize not working

Unanswered Question
Feb 2nd, 2010

Hi,

I'm trying to localize in Italian the PHONE 525G with firmware version 7.4.3.

My TFTP server IP is 192.168.1.55
My IP PHONE 525G IP is 192.168.1.4

I've put the spa525_EN_7_2_5.xml and the spa525_IT_7_2_5.xml files on the TFTP server.

Using the web browser on the PHONE 525G (192.168.1.4) I've configured the following string on the following menu (using admin login and advanced option):

Voice
Regional
Language

serv=tftp://192.168.1.55/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=Italian;x1=spa525_IT_7_2_5.xml;


BUT THE PHONE LOAD THE ENGLISH version.

I can see on the phone on the menu the option to use the italian language but the PHONE doesn't change it (still remain in english).

Can someone help me ?

Regards

Roberto Taccon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
juunda Thu, 02/04/2010 - 16:14

Greetings,

I have experienced similar problems when leaving the .xml name to it's original, I strongly suggest you simply re-name the file to a one word, no characters, no spaces, no dashes, no capital letters, no numbers for example            italian.xml            english.xml

I had to localize the same phone in Mexico and we used a free solar winds tftp server, followed all the steps in uploading them and it consistently failed, until we decided to  change the file names to a one word file and surely enough it worked after that.

I would give this a try and let me know.

Thanks.

Joachim Kern Fri, 02/05/2010 - 08:42

serv=tftp://192.168.16.100/;d0=English-US;x0=spa525_EN_7_2_5.xml;d1=Italian;x1=spa525_IT_7_2_5.xml;

I used the string above. Worked for me with firmware 7.4.3.

The phone loads the xml files from the tftp server when you actually select the Italian language for the first time on the phone display.

Check your tftp server when you actually select Italian on the display and press the SAVE softkey.

Currently I would verify that your tftp server works.

The display will show "Italian" as option when you save above setting, but again only when you select and save Italian as your language the phone will try to load the file from the TFTP server.

Make sure that your tftp server listens to requests.

Actions

This Discussion