Established VPN but client cannot access internet..Need Help.

Answered Question
Feb 2nd, 2010

Hello everyone,

I'm trying to get an ASA 5505 appliance working but still not successful. I managed to get the VPN client connected to the ASA but once connected,the vpn client cannot access the internet. I'm trying to route all the client's traffic to the VPN server so I dont want to do a split tunnelling. Below is rough sketch of the network testbed:

                                                                                                                  DNS:210.193.2.66
                                                                                                                            |
                                                                                                                            |
                                     Inside   ---------  Outside                         ---------          -------------------
                             192.168.1.1 |         |202.*.*.84          202.*.*.1|         |          [                  ]
                          ---------------------- ASA |-------------------------------------  GW  |----------[ INTERNET ]
                           |                   | 5505 |                    |                |         |          [                  ]
                           |                   | --------|                    |                 ---------           -------------------
                         Host_A                                          | 202.*.*.83
                       192.168.1.5                                -------------
                                                                       | NetGear |
                                                                       | Router    |
                                                                        --------------
                                                                             |192.168.2.1
                                                                             |
                                                                             |
                                                         Host_B --------|
                                 Physical Addr:192.168.2.2
                                      VPN Addr:192.168.3.1

The ASA 5505 config is as shown below:

Result of the command: "show running-config"

: Saved
:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 0cMYKRmmOdVhcSr4 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 202.*.*.84 255.255.255.128
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.224
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool vpnpool 192.168.3.1-192.168.3.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 202.128.171.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.128 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
client-update enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.20 inside
dhcpd dns 210.193.2.66 210.193.2.34 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy Reveal internal
group-policy Reveal attributes
vpn-tunnel-protocol IPSec
username alice password tnbrh7ICan8mnq/Y encrypted privilege 0
username alice attributes
vpn-group-policy Reveal
tunnel-group Reveal type remote-access
tunnel-group Reveal general-attributes
address-pool vpnpool
default-group-policy Reveal
tunnel-group Reveal ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:bfb0083a8eb2416e9cc27befe3b224d9
: end

I have this problem too.
0 votes
Correct Answer by Andrew MacTaggart about 6 years 10 months ago

some thoughts

same-security-traffic permit intra-interface

nat (outside) 1 your vpn client pool

asa sysopt connection permit-vpn

asa sysopt connection permit-ipsec

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Andrew MacTaggart Tue, 02/02/2010 - 22:06

some thoughts

same-security-traffic permit intra-interface

nat (outside) 1 your vpn client pool

asa sysopt connection permit-vpn

asa sysopt connection permit-ipsec

Actions

This Discussion

Related Content