How can I change CUE IP address on UC560?

Unanswered Question
Feb 2nd, 2010

I need to change the IP address on the CUE module because the IP address conflicts with an internal range, but doesn't seem to be working for me.  Via the CLI, I changed the Loopback 0 IP address, then on the integrated service engine I removed the defaulte gateway, put in the new ip, then set the gateway to the Loopback 0 IP.  I can't even ping the IP from the UC itself.

If anyone can send me any links or instructions on how to do this, would be much appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Trad Tue, 02/02/2010 - 22:23

Hi Audy,

Please confirm if your config looks like this:

Interface Integrated-Service-Engine0/0:

interface Integrated-Service-Engine0/0
       description cue is initialized with default IMAP group
       ip unnumbered Loopback0
       ip virtual-reassembly
       service-module ip address
       service-module ip default-gateway

And then the Loop back:

  interface Loopback0
       description $FW_INSIDE$
       ip address
       ip virtual-reassembl

Do the following once config is confirmed:

  1. Once you have made these changes, power the system down tottaly I.E remove the power from the machine
  2. Power the machine back up
  3. Wait about 7 minutes for the CUE to boot up before you do anything or log into anything
  4. Once you have given the system enough time try and session in to the CUE

This should make the changes, however you need to keep in mind that reloading the UC-500 does not reload the CUE, you can issue the command to reload the CUE but i prefer a complete shutdown, this way any changes should stick.

let us know how you go.



Audy Bautista Wed, 02/03/2010 - 08:02

That's exactly how my configs look. I will reload it now to see if it that works, thanks.

David Trad Wed, 02/03/2010 - 14:36

Hi Audy,

Let us know how you go with it after you do the Power Cycle of the system.



Audy Bautista Wed, 02/03/2010 - 15:24

Hi, I tried to do a reload but didn't work.  I won't be at the site to test the reload until at least Friday, will let you know.  Thanks.

David Trad Wed, 02/03/2010 - 15:46

Hi Audy,

Hi, I tried to do a reload but didn't work.  I won't be at the site to
test the reload until at least Friday, will let you know.  Thanks.

Just to confirm, you are not doing a reload but a full power cycle, a reload will not apply the settings to the CUE, you are best topower down the sytem and then power it back up, and yes you will need to be onsite for that.



John Platts Wed, 02/03/2010 - 16:39

I actually know a better method for restarting CUE. I know that in CCA 2.2 and later, you can right-click on the UC500 unit, and then select restart CUE. In addition, you can do the following in CLI to actually restart CUE:

UC520#service-m i0/0 se


(enter username and password if prompted)



Remember that you must actually use the service-m i0/0 se command to access the CUE module, and you have to execute the reload command from the CUE side. You will also have to be sure to make the IP address adjustments on the CUE side as well.

Steven Smith Wed, 02/03/2010 - 19:53

A few more changes are required. 

You probably have this in your config.

ip route Integrated-Service-Engine0/0

You will need to change it to then new IP and remove the current line.

You should look at ACLs that need to changes as well, including NAT ACLs.

Also, in the CUE config, there are some SIP commands that need to change IPs to point to the new IP of CME.

Audy Bautista Wed, 02/10/2010 - 12:07

Here's the complete configs of what I did to change the CUE IP on a UC540.  So far working fine, I hope I didn't miss anything.  Maybe someone from the Cisco side could look this over:

interface Loopback0
ip address

interface Integrated-Service-Engine0/0
no service-module ip default-gateway
service-module ip address
service-module ip default-gateway

no ip route Integrated-Service-Engine0/0
ip route Integrated-Service-Engine0/0

dial-peer voice 2000 voip
voice-class sip outbound-proxy ipv4: 
session target ipv4:

dial-peer voice 1003 voip
session target ipv4:
dial-peer voice 1005 voip
session target ipv4:

url services
url authentication

Steven Smith Wed, 02/24/2010 - 11:49

I would check your ACL's to make sure they are correct.

You should also look at CUE to make sure the NTP server is correct as well as any SIP server configurations in CUE.


This Discussion