AP connected to PoE port of WLC not associating to the WLC

Unanswered Question
Feb 3rd, 2010


I have a WLC 2106 and a 1100 series LAP.

A external DHCP server is configured on the WLC.

When I connect the LAP to the PoE port(port 7 / port 8) of the WLC, the AP is not associating to the WLC.

If I log into the console of the AP, it says, "Not sending CAPWAP discovery message because device does not have an IP" which indicated that the AP is unable to obtain a address from the DHCP server.

I have also tried configuring the WLC itself as the DHCP server. It does not help

But, when I connect the AP to the port of a switch , with no other configuration changed, the AP associates and everything works normally.

Also, if I configurw a static IP on the AP, the AP associates with the WLC when connected to port 7/8 of WLC.

I would be really thankful to anyone who could help me out.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
dancampb Wed, 02/03/2010 - 06:47

Make sure that the management and ap manager interfaces have their primary DHCP configuration pointed to the IP address of the management interface.  Also make sure the DHCP proxy is enabled on the controller.

abhishek.es Wed, 02/03/2010 - 07:04

First of all, thanks for your reply

I have enabled DHCP proxy on the controller.

About pointing the DHCP address on the manager and ap-management interface to that of the wlc management interface, I think it should be done only when using the internal DHCP server on the controller . I have already tried that and it does not solve the issue.When using an external DHCP server , should I not point the DHCP addresses to that of the external DHCP server ??

Leo Laohoo Tue, 02/23/2010 - 13:13

Sounds like the AP, if it has a valid IP address, may not be able to contact the Management IP address of the WLC.  What's the link between the WLC and the switch configured like?  Is it tagged or untagged?  And what's the switch port configured like?

pvaysberg Tue, 02/23/2010 - 13:21

The LWAP is connectied directly to port 8 of the WLC 2106.  I see it in the CDP information on the WLC.

pvaysberg Tue, 02/23/2010 - 15:08

Just got off the phone with TAC and we resolved the problem I had that was similar to your's.

We configured the controller to hand our DHCP that was in the same subnet as the ap manger and management interfaces.  The root of the problem was that the AP still needs to get an IP somehow, and all the ports on the back of the controller (unless otherwise assigned) are part of vlan 1( the management vlan)

The other option is to static assign an IP in the management interface's range, then you don't need DHCP.

Hope this helps.  Feel free to post back and I will try to assist as much as I can.


This Discussion

Related Content