no busy tone by unknown number h323 and cucm7.1

Unanswered Question
Feb 3rd, 2010
User Badges:

hi,


i configured a CUCM 71 and a H323 GW to PSTN. All works fine, but when I call an unknown number I get a Ringtone, no busy tone. The number is not configured in CUCM.


what can i do?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
markbatts Wed, 02/03/2010 - 06:30
User Badges:
  • Bronze, 100 points or more

The number you are calling have you ran it through Dial plan Route Plan report.You may have a translation etc that is matching it.Also is this an external or internal call?


Mark

Support Albakom Wed, 02/03/2010 - 07:07
User Badges:

markbatts schrieb:


The number you are calling have you ran it through Dial plan Route Plan report.You may have a translation etc that is matching it.Also is this an external or internal call?


Mark



sh dialplan number 9999602
Macro Exp.: 9999602
No match, result=1



The prefix is 9999 the destinations are 3digit Numbers, e.g. 602.

The call comes frome PSTN through H323 to CUCM 7.1.3.

The destination here- 602 -  is not configured in CUCM. But if I call this number (9999602) I hear a the ringtone. But I want to hear a busy or somewhere like "unallocated number".

If I call 9999123, where 123 is a configured destination, all works fine.


I think the CUCM give back the unallocated number to Gateway, but it forwards this not to carrier PSTN. Is there a command to force this? Or a thing to configure at CUCM?

markbatts Wed, 02/03/2010 - 07:34
User Badges:
  • Bronze, 100 points or more

can you send the output of a debug isdn q931 on the gateway please.I would like to check what we are sending back to the telco

Support Albakom Wed, 02/03/2010 - 07:41
User Badges:

Feb  3 15:38:12.540: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x305B
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839B
                Exclusive, Channel 27
        Calling Party Number i = 0x2180, 'XXXXX630'
                Plan:ISDN, Type:National
        Calling Party Number i = 0x2183, 'XXXXX60'
                Plan:ISDN, Type:National
        Called Party Number i = 0xC1, '9999602'
                Plan:ISDN, Type:Subscriber(local)
Feb  3 15:38:12.540: ISDN Se0/0/0:15 Q931: Received SETUP  callref = 0xB05B callID = 0x202B switch = primary-net5 interface = User
Feb  3 15:38:12.556: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xB05B
        Channel ID i = 0xA9839B
                Exclusive, Channel 27
Feb  3 15:38:12.576: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8  callref = 0xB05B
        Progress Ind i = 0x8188 - In-band info or appropriate now available
Feb  3 15:38:19.424: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x305B
        Cause i = 0x8090 - Normal call clearing
Feb  3 15:38:19.428: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0xB05B
Feb  3 15:38:19.448: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x305B

markbatts Fri, 02/05/2010 - 02:07
User Badges:
  • Bronze, 100 points or more

If you look at the debug we are actually sending out an alerting message which is probably causing the issue.If you run a route plan report in callmanager for anything starting with "6" , do you get any results.


mark

Support Albakom Fri, 02/05/2010 - 03:40
User Badges:

markbatts schrieb:


If you look at the debug we are actually sending out an alerting message which is probably causing the issue.If you run a route plan report in callmanager for anything starting with "6" , do you get any results.


mark

I get results. There was more than one destination beginning with "6". But no destination with "602".

Actions

This Discussion