PAP one-way authentication failing..

Unanswered Question

hi,


I connected two routers R1 and R2 via serial link to configure ppp pap uni-directional authentication but its not working. following is the config


R1:

username PAPU password cisco

interface Serial0/0
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
ppp authentication pap
end


R2:

interface Serial0/0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
ppp authentication pap callin
ppp pap sent-username PAPU password 0 cisco
end


and it is showing the following msg when i run debug pap authenication on both routers


*Mar  1 01:04:32.467: Se0/0 PPP: Authorization required
*Mar  1 01:04:32.675: Se0/0 PPP: Authorization required
R1#
*Mar  1 01:04:34.671: Se0/0 PPP: Authorization required
R1#u
*Mar  1 01:04:36.619: Se0/0 PPP: Authorization required


Did i configure some thing wrong..



Regards


nareh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Wed, 02/03/2010 - 13:42
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Remove


ppp authentication pap callin


From R2


You are making R2 an authentication server as well while per your output and requirements, R2 is just the client.

Giuseppe Larosa Wed, 02/03/2010 - 13:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nareh,


check if AAA new model is configured on your routers


or if you like post

sh run | inc aaa


Edit:

I think Edison is on spot here


Hope to help

Giuseppe

Actions

This Discussion