what is the cause of cisco 2950 high memory utilization?

Unanswered Question
Feb 3rd, 2010

cisco switch# showmemory summary

                                Head      Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)

Processor   80BA72C0     4547904     3670468      877436      597568        832724

             I/O   A0750D80     4547872     2611776     1936096     1916508      1907688

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Leo Laohoo Thu, 02/04/2010 - 14:21

It's really hard for anyone to determine the cause of the issue if sufficient information is not available.  Can you kindly post your config?

mohammed.almeqbali Sat, 02/06/2010 - 20:07

HQ_IFDA_F6_SW21#show running-config

Building configuration...

Current configuration : 8745 bytes

!

! No configuration change since last restart

!

version 12.1

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

service sequence-numbers

!

hostname HQ_IFDA_F6_SW21

!

aaa new-model

aaa authentication login default group tacacs+ local

aaa authorization config-commands

aaa authorization exec default group tacacs+ local

aaa authorization commands 1 default group tacacs+ local

aaa authorization commands 15 default group tacacs+ local

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

enable secret 5 00000000000000000000000000

enable password 0 00000000000000000

!

username admin password 0 000000000000000000000000000

username  cisco privilege 15 password 0 00000000000000000

clock timezone GMT 4

ip subnet-zero

no ip domain-lookup

!

spanning-tree extend system-id

!

!

interface Port-channel1

no ip address

flowcontrol send off

!

interface FastEthernet0/1

switchport access vlan 76

switchport trunk native vlan 75

switchport trunk allowed vlan 1,75,252,1002-1005

switchport mode trunk

switchport voice vlan 252

no ip address

speed 100

spanning-tree portfast trunk

!

interface FastEthernet0/2

switchport access vlan 71

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 18

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 71

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 71

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 75

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 73

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/8

switchport access vlan 18

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/9

switchport access vlan 72

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/10

switchport access vlan 77

no ip address

speed 10

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/11

switchport access vlan 74

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/12

switchport access vlan 71

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/13

switchport access vlan 22

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/14

switchport access vlan 73

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/15

switchport access vlan 18

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/16

switchport access vlan 22

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/17

switchport access vlan 72

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/18

switchport access vlan 72

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/19

switchport access vlan 71

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/20

switchport access vlan 71

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/21

switchport access vlan 140

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast trunk

!

interface FastEthernet0/22

switchport access vlan 140

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/23

switchport access vlan 76

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/24

switchport access vlan 76

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/25

switchport access vlan 72

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/26

switchport access vlan 75

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/27

switchport access vlan 72

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/28

switchport access vlan 78

no ip address

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/29

switchport access vlan 18

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/30

switchport access vlan 22

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/31

switchport access vlan 72

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/32

switchport access vlan 76

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/33

switchport access vlan 73

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/34

switchport access vlan 72

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/35

switchport access vlan 76

switchport trunk native vlan 75

switchport trunk allowed vlan 1,75,252,1002-1005

switchport mode trunk

switchport voice vlan 252

no ip address

duplex full

speed 100

spanning-tree portfast trunk

!

interface FastEthernet0/36

switchport access vlan 22

no ip address

duplex full

speed 100

no cdp enable

channel-group 1 mode desirable

!

interface FastEthernet0/37

switchport access vlan 76

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/38

switchport access vlan 73

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/39

switchport access vlan 73

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/40

switchport access vlan 72

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/41

switchport access vlan 73

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/42

switchport access vlan 72

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/43

switchport access vlan 18

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/44

switchport access vlan 18

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/45

switchport access vlan 73

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/46

switchport access vlan 72

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/47

switchport access vlan 140

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/48

switchport access vlan 22

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 1-139,176-4094

switchport mode trunk

no ip address

udld enable

!

interface GigabitEthernet0/2

switchport trunk allowed vlan 1-140,176-4094

switchport mode trunk

no ip address

udld enable

!

interface Vlan1

ip address 10.6.1.48 255.255.255.0

no ip route-cache

!

ip default-gateway 10.6.1.1

ip http server

!

logging 10.6.1.254

snmp-server engineID local 00000009020000036B919780

snmp-server community private RW

snmp-server community public RO

snmp-server location IDF, Block4 - Polyclinic

snmp-server contact Network Section

snmp-server chassis-id 0x03

snmp-server enable traps snmp authentication linkdown linkup coldstart

snmp-server enable traps config

snmp-server enable traps syslog

snmp-server enable traps entity

snmp-server enable traps rtr

snmp-server enable traps c2900

snmp-server enable traps vtp

snmp-server enable traps vlan-membership

snmp-server enable traps MAC-Notification

snmp-server enable traps hsrp

snmp-server enable traps cluster

snmp-server host 10.6.1.254 private  tty config c2900 vtp vlan-membership snmp

tacacs-server host 10.6.5.130 key 00000000

tacacs-server host 10.6.5.131 key 00000000

!

line con 0

password 7 0000000000000000

line vty 0 4

password 7 0000000000000000

line vty 5 15

password 7 0000000000000000

!

ntp clock-period 17179900

ntp server 10.6.1.1

end

Reza Sharifi Sat, 02/06/2010 - 20:57

Hello Mohammed,

Memory utilization does not always mean three is problem with your switch. 

I see on ports 0/1 and 0/35 you have vlan 1002-1005 enabled.  These VLANs are Cisco default for FDDI and Token Ring.  I also see on your uplink trunks you have up to VLAN 4094 enabled.  Are there any reasons for theses? It is good practice to allow only the VLANs that you need on the Trunk ports and no more.

Also how high is the CPU utilization?

Can you post "sh process CPU sort"?

HTH

Reza

johnlloyd_13 Sat, 02/06/2010 - 22:57

most likely caused by a STP loop. could you post your show spanning-tree? you might want to consider RSTP on your switched LAN.

mohammed.almeqbali Sun, 02/07/2010 - 19:45

Hi,

This is the show processes cpu,

HQ_IFDA_F6_SW21#show processes cpu

CPU utilization for five seconds: 14%/3%; one minute: 16%; five minutes: 15%

PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process

   1        1116     68934     16   0.00%  0.00%  0.00%   0 Load Meter

   2     7688072   7104597   1082   0.73%  1.13%  1.09%   0 Spanning Tree

   3      202708     40845   4962   0.00%  0.06%  0.05%   0 Check heaps

   4           0         1      0   0.00%  0.00%  0.00%   0 Chunk Manager

   5          80       173    462   0.00%  0.00%  0.00%   0 Pool Manager

   6           4         2   2000   0.00%  0.00%  0.00%   0 Timers

   7         704         8  88000   0.00%  0.00%  0.00%   0 Entity MIB API

   8        1980     68930     28   0.00%  0.00%  0.00%   0 HC Counter Timer

   9      102488    207856    493   0.08%  0.04%  0.01%   0 ARP Input

  10        1992     16948    117   0.00%  0.00%  0.00%   0 Net Input

  11           0         1      0   0.00%  0.00%  0.00%   0 Critical Bkgnd

  12      568616    434895   1307   0.00%  0.02%  0.02%   0 Net Background

  13        4960     12261    404   0.00%  0.00%  0.00%   0 Logger

  14        9392    344416     27   0.00%  0.00%  0.00%   0 TTY Background

  15        3980    344428     11   0.00%  0.00%  0.00%   0 Per-Second Jobs

  16           0         2      0   0.00%  0.00%  0.00%   0 Calhoun Storm Co

  17    33655108   7744332   4345   9.42%  9.79%  9.86%   0 Calhoun LED Proc

  18     2776680    682883   4066   0.57%  0.64%  0.65%   0 Calhoun Statisti

  19        3284     68934     47   0.00%  0.00%  0.00%   0 Compute load avg

  20       51792      5744   9016   0.00%  0.00%  0.00%   0 Per-minute Jobs

  21      464416   1714304    270   0.00%  0.15%  0.11%   0 HMATM Learn proc

  22      619552   7910510     78   0.16%  0.15%  0.14%   0 CalhounPM

  23     1367608   1714222    797   0.24%  0.34%  0.36%   0 Link Status Proc

  24           0         1      0   0.00%  0.00%  0.00%   0 CalhounInsIpopti

PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process

  25       32620     49454    659   0.00%  0.00%  0.00%   0 CDP Protocol

  26       99408    317618    312   0.16%  0.03%  0.00%   0 IP Input

  27      494980    254178   1947   0.00%  0.04%  0.05%   0 DTP Protocol

  28         836     34465     24   0.00%  0.00%  0.00%   0 EtherChnl

  29       98484    174373    564   0.00%  0.01%  0.00%   0 VLAN Manager

  30           0         2      0   0.00%  0.00%  0.00%   0 PI MATM Aging Pr

  31       15236    344692     44   0.00%  0.00%  0.00%   0 UDLD

  32         284       337    842   0.00%  0.00%  0.00%   0 dot1x

  33          36        25   1440   0.00%  0.00%  0.00%   0 DHCPD Receive

  34           0         1      0   0.00%  0.00%  0.00%   0 HTTP Timer

  35           0         1      0   0.00%  0.00%  0.00%   0 RARP Input

  36         128       212    603   0.00%  0.00%  0.00%   0 TCP Timer

  37          48        15   3200   0.00%  0.00%  0.00%   0 TCP Protocols

  38           0         1      0   0.00%  0.00%  0.00%   0 Socket Timers

  39        1300      3206    405   0.00%  0.00%  0.00%   0 L2MM

  40       18288    109735    166   0.00%  0.00%  0.00%   0 MRD

  41           0         1      0   0.00%  0.00%  0.00%   0 IGMPSN

  42      116932    110044   1062   0.00%  0.00%  0.00%   0 IGMP Snooping Pr

  43      921164   3689285    249   0.00%  0.44%  0.21%   0 IGMP Snooping Re

  44          16      5745      2   0.00%  0.00%  0.00%   0 pSecureProcess

  45          12      4311      2   0.00%  0.00%  0.00%   0 Cluster L2

  46        1448     34465     42   0.00%  0.00%  0.00%   0 Cluster RARP

  47        1324     43122     30   0.00%  0.00%  0.00%   0 Cluster Base

  48       10396       956  10874   1.47%  0.26%  0.16%   1 Virtual Exec

  49           0         2      0   0.00%  0.00%  0.00%   0 Router Autoconf

PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process

  50       27532      6170   4462   0.00%  0.00%  0.00%   0 Syslog Traps

  51           0         1      0   0.00%  0.00%  0.00%   0 AggMgr Process

  52       65336   2291878     28   0.00%  0.00%  0.00%   0 PM Callback

  53           4         5    800   0.00%  0.00%  0.00%   0 VTP Trap Process

  54          72      2873     25   0.00%  0.00%  0.00%   0 DHCPD Timer

  55           0         2      0   0.00%  0.00%  0.00%   0 STP STACK TOPOLO

  56           4         2   2000   0.00%  0.00%  0.00%   0 STP FAST TRANSIT

  57         176        22   8000   0.00%  0.00%  0.00%   0 SpanTree Helper

  58           0         2      0   0.00%  0.00%  0.00%   0 PAgP

  59           0         2      0   0.00%  0.00%  0.00%   0 IP NAT Ager

  60           0         1      0   0.00%  0.00%  0.00%   0 SNMP Timers

  61      463900     51962   8927   0.00%  0.06%  0.08%   0 IP SNMP

  62        3124        83  37638   0.00%  0.00%  0.00%   0 SNMP ConfCopyPro

  63           8         7   1142   0.00%  0.00%  0.00%   0 SNMP Traps

  64        9912    347316     28   0.00%  0.00%  0.00%   0 NTP

  65           0         2      0   0.00%  0.00%  0.00%   0 AAA Accounting

  66         112       239    468   0.00%  0.00%  0.00%   0 TACACS+

Thanks,

Actions

Login or Register to take actions

This Discussion

Posted February 3, 2010 at 10:13 PM
Stats:
Replies:5 Avg. Rating:
Views:2041 Votes:0
Shares:0
Categories: Switches
+

Related Content

Discussions Leaderboard

Rank Username Points
1 14,997
2 8,150
3 7,720
4 7,078
5 6,723
Rank Username Points
175
80
60
59
55