VMO & Web SA problem

Unanswered Question
Feb 4th, 2010

When any attempt is made to configure a subscriber account or a call handler, the following message pops up on the local computer:

Enter information for telephone record and playback.

--------------------------------------------------------------------------------

Resource: UnityVoiceServerNameHere

User name:
Password:
Domain:

I enter my domain credentials and they are not accepted.

If I cancel the logon prompt and select the record button for a subscriber account, this pop's up:

Cisco Unity Access was denied when connecting to the voice server.  To use the telephone you must be logged into Windows using the account associated with your subscriber account.

I have followed the recommended procedure for completely removing the VMO client.

I deleted the AVmediaMasterCtrlClass add-on from IE7 add-ons.

Removed all Java and reinstalled with latest version.

Then reinstalled VMO client and imported the AVMediaMasterCtrlClass certificate back into IE7.

I can access my personal voice mail using the client without a problem.

Unity 7.0.2

VMO 7.0.2

Exchange 2003SP1

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ginger Dillon Thu, 02/04/2010 - 16:24

Hi -

I don't believe this is a ViewMail problem.  Are you a Unity administrator using the userid you are logged onto the PC with?  If so, you can put your account into a Unity class of service that has the permissions to update subscribers.  If the Windows account you are logging onto your PC with is NOT a Unity subscriber, i.e. you are using an administrator account; the recommended option is to use the grantunityaccess utility on the Unity server.  You can assign yourself Unity Enterprise Admin rights by running the grantunityaccess utility.  From the command line that opens when you start this tool, enter grantunityaccess -u domain\user -s eadmin (where user is the PC account you are using on the PC).  Give this a try and see if it corrects your problem.

Hope this helps!  Ginger

Kelly Dodd Tue, 02/09/2010 - 06:39

Yes, I am a Unity Admin logging in with my user ID.  To my knowledge, nothing changed on my end.  I'm configured with the Default Administrator COS.

I did remove myself from the Admin COS and attempt the method you described using GrantUnityAccess utility but that returned the same result:

"Enter Netwok Password"

I can go directly to the Unity server and open the Web SA and click on a user.  If I select the option to play the end user's message, my phone will ring and I can listen to the message.

Thanks for your help Ginger.

Ginger Dillon Tue, 02/09/2010 - 10:41

Hi Kelly -

The message you are getting "Enter network password" sounds like the PC is in a different domain than the Unity server.  If that is not the case, I am wondering if there isn't something else blocking the PC to the Unity server.  It could be a variety of causes - antivirus, DCOM got disabled on the workstation, DNS between PC and Unity server, IIS settings like proxy server, trusted sites etc.

Check out this great forum link from Cisco forum expert Brad! - https://supportforums.cisco.com/message/2007286#2007286

Here are a few additional links that might help:

Ciscopca workstation setup - http://www.cisco.com/en/US/docs/voice_ip_comm/unity/5x/administration/guide/ex/5xcusag270e.html#wp1048299

SA Web Troubleshooting - http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a00801ba0ef.shtml#o

Link that discusses DCOM and how to correct (plus other checks) - https://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a0080b14515.shtml

CiscoPCA troubleshooting - http://www.cisco.com/en/US/docs/voice_ip_comm/unity/5x/troubleshooting/guide/ex/5xcutsg170e.html

Hope these help!  Ginger

Ginger Dillon Tue, 02/09/2010 - 11:31

Hi Kelly -

Something just dawned on me for you to check - a few years back we had this same problem with several user PCs.  You might check it out to see if it applies to your problem PC(s).

Web Pages That Contain the Media Master Control Bar Do Not Load Properly When Google Desktop Search Is Installed

When Google Desktop Search is installed on a subscriber workstation that uses Windows XP, the pages of the Cisco Personal Communications Assistant (PCA) and the Cisco Unity Administrator do not load properly in the browser.

Many regards, Ginger

Kelly Dodd Tue, 02/16/2010 - 11:42

Ginger-

The problem was the DCOM service had been turned off on my computer unknown to me. Not sure how that happened (Group Policy update/change?), but checking the box to enable Distributed COM and then stopping and restarting the IIS service restored the functionality.

I did not have to add the Network Service and Anonymous accounts to get it to work.

Thanks again.

K.

Actions

This Discussion