L2TP Dialer to cables modem?

Unanswered Question
Feb 5th, 2010


I have just received my new Cisco 871W router and I need to configure it to be to dial to cables modem using L2TP or PPTP in order to make a connection to the internet.

I can see that in CP Express there is only PPPoE and there is no L2TP or PPTP why?

Anyway, I have received the following script for L2TP but after set it up using CP Professional 1.3 still there is no connection to the internet.

Will be much appreciated for any help,


pseudowire-class ISP

encapsulation l2tpv2


interface FastEthernet4

description WAN interface to ISP

ip address dhcp

ip  virtual-reassembly

load-interval 30

duplex auto

speed auto


interface  Virtual-PPP1

description L2TP dialer to ISP

ip address negotiated

ip flow  ingress

ip flow  egress

ip nat  outside

ip  virtual-reassembly

ppp pap sent-username MyUser password MyPass

ppp ipcp dns request accept

pseudowire cablelns.012.net.il 2 pw-class ISP

ip route Virtual-PPP1

ip route cablelns.012.net.il FastEthernet4


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Fri, 02/05/2010 - 01:42

Hello Asaf,

in a similar thread the solution was to use the DHCP keyword in the static route towards L2TP terminator address

try to change from:

ip route cablelns.012.net.il FastEthernet4


ip route cablelns.012.net.il Fast4 dhcp

this option allows to learn next-hop ip address dynamically by DHCP server



you can check what happens using:

term mon

debug ppp neg

debug ppp auth

Hope to help


asafgoldman Fri, 02/05/2010 - 02:09

Hello giuslar,

I have tried to ad dhcp and also to change cablelns.012.net.il to it IP but still can't connect to the internet.

Attached is a text file with Debug.

Kind Regards,


Giuseppe Larosa Fri, 02/05/2010 - 02:26

Hello Asaf,

the debug looks like good: PPP negotiation and PPP authentication phases are passed state OPEN = OK and later IPCP (negotiation of IP parameters over the PPP session) is performed.

What exactly are the problem you face?

I look again at initial configuration you may be missing  the NAT part.


I see virtual-ppp has ip nat outside on it.

get a telnet or console session in your router and try to ping some public ip address on the internet from the router.

if the router can go to the internet, but devices on internal LAN cannot the issue is on the NAT part.

Hope to help


asafgoldman Fri, 02/05/2010 - 05:03


I did a ping, attached a jpg image but I think it was not successful.

Also I have tried to go to NAT basic settings but cannot continue as CP is required that a WAN connection will be available.


Giuseppe Larosa Fri, 02/05/2010 - 11:42

Hello Asaf,

connect to the router using the console cable to go on troubleshooting or using a telnet to internal LAN

check with

sh users

if the PPP session stays up, it does it should be listed in the output of this show.

Hope to help


asafgoldman Fri, 02/05/2010 - 23:43

Hi Giuseppe,

For several years I am using CheckPoint products and it is so easy to maintain them.

For a new server my ISP recommended to me to try Cisco as they are better but after I messed around with the 871W for two days I have found it very hard to maintain also I could not connect it to the internet using L2TP and I am going to return it to the vendor I purchased it form.

Also in CheckPoint products there is a dialer for PPPoE (ADSL), and PPTP (Cables) so why Cisco 871 does not have this simple PPTP or L2TP option out of the box an using only PPPoE option?

In CheckPoint products all are done from a very intuitive GUI Interface not need to mess around with CLI commands and scripts and all are done thru the appliance itself with no need for Java on the PC and no need for three different administration software's like the 871 needs, one is CP Express, two is CP Professional and three is the one for the Wireless.

Many thanks for trying to help me with my issue.

Kind Regards,



This Discussion