Dynamic Hunt Group Membership - Key not active here

Answered Question
Feb 5th, 2010

Greetings, im trying to configure dynamic hunt group membership for a small telesales team, however when trying to configure CME using the HLog "Agent Status Control" method i am unable to get the Softkey to activate on the IP Phone. ie "Key is not active here"


Looking at the CME admin guide it does mention having to assign wildcards the the hunt group but it was my understanding that this was only required when following the "Dynamic Membership" feature, this configuration has been taken from page 718/719 on the latest admin guide.


Has anyone got this working succesfully using this method if so is there something im missing? I can configure this feature using wildcards and the ephone-hunt login command under the DN but i would prefer i could just use the Hlog key for simplicity sake.


Regards


CME Version 7.1


Here's my current telephony service configuration:

(I have tried using both fac standard and fac custom)


telephony-service
hunt-group logout HLog

fac custom ephone-hunt hlog #21
fac custom trnsfvm #22



Hunt Group configuration:


ephone-hunt 3 peer
pilot 2001
list 8367, 8369, 8368, 8378, 8375, 8158, 8345
final 2000
timeout 15, 15, 15
no-reg pilot
description Telesales Department
display-logout Logged Out


Ephone Configuration


ephone  4
video
mac-address 001E.BE90.7978
ephone-template 3
type 7940
button  1:4


Ephone Template


ephone-template  3
softkeys idle  Newcall Redial Cfwdall Gpickup Pickup HLog
softkeys seized  Redial Pickup Gpickup HLog
softkeys alerting  Endcall
softkeys connected  Hold Confrn Trnsfer TrnsfVM LiveRcd Endcall HLog
softkeys ringing  Answer
features blocked  Park

I have this problem too.
1 vote
Correct Answer by Paolo Bevilacqua about 6 years 10 months ago

Go to 8.0(10) first, that should solve the softkey already.

Correct Answer by Paolo Bevilacqua about 6 years 10 months ago

See:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_l1ht.html#wp1035818

Please remember to rate useful posts clicking on the stars below.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Mark Rigby Fri, 02/05/2010 - 04:43

Thank you for your reply apologies i forgot to include the DN configuration

 

ephone-dn  4  dual-line
  number 8367 secondary 01211118367 no-reg both
  pickup-group 2
  label 0121 111 (8367)
  description Telesales Agent
  name Telesales Agent
  call-forward busy 9000
  call-forward noan 9000 timeout 15
  corlist incoming user-international
  no huntstop

 

I have checked that the DN isn’t shared, overlaid or monitored on another extension, one thing to note is that if i remove the "hunt-group logout hlog" command from the telephony service configuration the key becomes active but isnt functional.

 

I have tried removing the DN from the hunt group and adding wildcard characters instead, i have also tried adding the "ephone-hunt login" command under the DN to no effect either.

 

Very confusing!

Mark Rigby Fri, 02/05/2010 - 06:08

Tried removing the Pickup-Group as well but no luck, ive got a UC500 knocking arround may be wothwhile to flatten it and try a vanilla build, very strange though.


Regards

Mark Rigby Fri, 02/05/2010 - 07:00

Ill give that a go now.


Edit: Looking at Cisco.com the version only goes to v8.1(2) for 7940/7960 phone load, am i looking in the wrong place.


Regards


Mark Rigby Fri, 02/05/2010 - 08:34

Not having much luck all those loads are for CUCM, im going to try one from the v8 as a last desperate act before i reload the router although the same behavior is shown on a 7941G handset also..possibly a bug.


Edit: Scratch that v8 uses the same load as well, reload it is then! There are a couple of bugs open one relating to extension mobility profiles which i dont use although i have a logout profile configured for demonstration purposes, just removed it and received this.


Feb  5 16:36:36.386: %ALIGN-3-SPURIOUS: Spurious memory access made at 0x40C516E8z  reading 0x4
Feb  5 16:36:36.386: %ALIGN-3-TRACE: -Traceback= 0x40C516E8z 0x40C51DB0z 0x41861234z 0x418872B4z 0x43691074z 0x43681F98z 0x430



Oh crap, definitely a reload i think!


Regards

Paolo Bevilacqua Fri, 02/05/2010 - 09:12

Loads are universal.

Get the .ZIP file and copy all files to router. With recent IOS, is not necessary anymore to configure tftp-server.

I had the same exact issue and 8.1.2 fixed that.

Mark Rigby Mon, 02/08/2010 - 15:53

Thank you for your continued support i certainly wasn’t aware that the tftp-server command was no longer required and havent seen it listed in the documentation either humm interesting, i shall give the updated files a go when im next in the office.

 

Regards

Mark Rigby Wed, 02/10/2010 - 09:23

Much appreciated, thank you for information, ill let you know how the i get along with the new phone load.


Regards

Mark Rigby Thu, 02/11/2010 - 10:36

Greetings again, i have added the phone load to CME but the 7940's dont take the new load, i have tried re-creating the CNF files, reloading the router and factory resetting each 7940 handset to ill effect.

Following Router Reload

DeviceName        CurrentPhoneload       PreviousPhoneload      LastReset     
====================================================================

SEP001EF727B66E   8.0(5.0)                                      CM-NAKed      

SEP001EF7278A39   8.0(5.0)                                      CM-NAKed      
SEP001FCAE80429   8.0(5.0)                                      CM-NAKed      

Following Reset


DeviceName        CurrentPhoneload       PreviousPhoneload      LastReset     
===================================================================== 
SEP001EF727B66E   8.0(5.0)               8.0(5.0)               Initialized 
SEP001EF7278A39   8.0(5.0)               8.0(5.0)               Initialized 
SEP001FCAE80429   8.0(5.0)               8.0(5.0)               Initialized    

!

it-cme-2811#show telephony-service tftp-bindings
tftp-server flash:/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:/P00308010200.loads alias P00308010200.loads

!
telephony-service
load 7960-7940 P00308010200.loads

Regards

Mark Rigby Fri, 02/12/2010 - 16:51

Thank you very much, went to load 8.0(10) then 8.1(2) all is working fine now.


Regards

David Lin Fri, 07/25/2014 - 10:18

Having the same problem on CME 10.0 + firmware 9-3-1.

Under telephony-service, I have following two lines, 

 hunt-group logout HLog
 fac standard

then in ephone-dn, added ephone-hunt login

The HLog key is grey-out. dialed by *3 didn't work either. Same config on CME8.8+F/W 9-2-3 works fine.

Took out the hunt-group logout HLog under telephony-service, the key appeared as normal but didn't do anything when pressed on it.

Not sure this is firmware issue? But the new phone has to use 9-3-1 or above.

 

Gear Misner Fri, 01/02/2015 - 14:11

David,

Did you ever figure this out?  Running into the same issue...

Anas Abueideh Sun, 01/04/2015 - 21:59

Hi,

Open new thread is better than replying a thread has 5 years old

Regards

Anas

Actions

This Discussion