Nexus 1000V - Can not see VEM in VSM

Unanswered Question
Feb 5th, 2010

Hello,

We are trying the version 4.0(4)SV1(2) and we can not see the VEM in the VSM yet. We don't see the "System Uplink" port profile assigned to a physical interface and we think that maybe this is the problem.

This is our config of port-profile

port-profile type ethernet system-uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan all
  no shutdown
  system vlan 22-23
  state enabled

port-profile type vethernet vlan-22
  vmware port-group
  switchport mode access
  switchport access vlan 22
  no shutdown
  state enabled
port-profile type vethernet vlan-23
  vmware port-group
  switchport mode access
  switchport access vlan 23
  no shutdown
  state enabled

svs-domain
  domain id 50
  control vlan 22
  packet vlan 23
  svs mode L2

Thank you! Celeste

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
kanglee Sun, 02/07/2010 - 12:09

Simon,

This issue can be caused by multiple reasons but there are few things to check first at initial configuration. Your vem, esx host, has to communicate to vsm on control vlan. This is like backplane on your switch. One way to verify end-to-end connectivity for control vlan is creating secondary service console interface with control vlan port-group. This doesn't have to be routable. Just between hosts, especially the host that has vsm and other hosts with vem.

Once that is verified then you can do the same thing for packet vlan to make sure. Next step is to check if you have installed the vem installation. You can login to esx host as root privilege and do vem status. Then it will tell you if vem is running or not. Also, you can check the license issue as well

N1KV-1# sh module vem mapping
Mod     Status          UUID                                    License Status
---     -----------     ------------------------------------    --------------
  3      powered-up     fe95c396-6c97-11d9-1111-00000000004f    licensed
  4      powered-up     fe95c396-6c97-11d9-1111-00000000006f    licensed
  5      powered-up     fe95c396-6c97-11d9-1111-00000000007f    licensed
  6      powered-up     fe95c396-6c97-11d9-1111-00000000005f    licensed
  7      powered-up     fe95c396-6c97-11d9-1111-00000000003f    licensed
  8      powered-up     fe95c396-6c97-11d9-1111-00000000002f    licensed

[root@ESX18-2-1 ~]# vem status

VEM modules are loaded

Switch Name    Num Ports   Used Ports  Configured Ports  MTU     Uplinks  
vSwitch0       32          1           32                1500             
DVS Name       Num Ports   Used Ports  Configured Ports  Uplinks  
SJ-N1KV-1      256         58          256               vmnic0,vmnic1

VEM Agent (vemdpa) is running

[root@ESX18-2-1 ~]#

c_simon Tue, 02/09/2010 - 12:28

Hi Kang,

We test the connectivity with our Packet and Control Vlans, and it works fine, but we still not seeing the VEM in VSM

The sh module vem mapping shows nothing:

VSM-1000v# sh module vem mapping

Mod     Status          UUID                                    License Status

---     -----------     ------------------------------------    --------------

VSM-1000v#

And the vem status command in ESX shows that the agent is running and loaded.

VSM and VM are running on the same ESX host.

Thank you!

Celeste

kanglee Tue, 03/09/2010 - 05:45

If you are sure control, packet vlan have configured correctly, then you can try to remove that host from dvs and add back in. It is better to choose the vmnic when you add the host to the N1K rather than adding it later. N1K needs at least one vmnic to connect to vsm. This has to be mapped on your system uplink.

Then you can try to restart the host or vem restart on the host.

thanks

jean.kobben Thu, 10/07/2010 - 10:36

Hello,

we do have the same Problem.

Installed is the Nexus1000v.4.0.4.SV1.3a

The latest VEM (VEM410-201007311) is installed on ESXi4.1

Packet VLAN and Control VLAN are testet. Communication works fine.

The Hosts don't register to the VSM.

VSM Logging says:

2010 Oct  7 17:05:24 DF-ESX-V-01-PRZ %VMS-5-DVS_HOSTMEMBER_INFO: A host with name=[HOST2] and uuid=[a62ba661-7
74b-3f10-0069-00238b428590] is added to the dvs. The host is not found  as a module in the VSM configuration.

We have Installed the VEM manually, per VUM and automaticaly per VUM.

Regards

Jean

sachthak Thu, 10/07/2010 - 10:46

Is your VSM running on the N1KV port profiles vlan-22 and vlan-23 for the control and packet interface? If so, you'll have to make both of those system vlans in the port profile as well.

Also have you added your pnic to the uplink port profile from the DVS networking view on the host?

Thanks,

sachin

jean.kobben Thu, 10/07/2010 - 11:36

Hello Sachin,

we use VLAN 900 and 901 for Packet and Control.

Both VLANs are defined as system vlans.

Regards

Jean

sachthak Thu, 10/07/2010 - 11:38

Could you post the port profile config for your uplink/veth profiles, svs connection and svs domain if possible?

Also could you paste the output of vemcmd show version on the host.

thanks,

sachin

jean.kobben Thu, 10/07/2010 - 11:51

N1Kv# sh svs domain

SVS domain config:

  Domain id:    1

  Control vlan: 901

  Packet vlan:  900

  L2/L3 Control mode: L2

  L3 control interface:  NA

  Status: Config push to VC successful.

N1kv# sh svs connections

connection duesseldorf:

    ip address: 172.34.57.16

    remote port: 80

    protocol: vmware-vim https

    certificate: default

    datacenter name: Harvard

    DVS uuid: 61 de 1f 50 8d 07 26 fa-2a fa de 91 4b bc c9 d8

    config status: Enabled

    operational status: Connected

    sync status: Complete

    version: VMware vCenter Server 4.1.0 Build-258902

DF-ESX-V-01-PRZ# sh port-profile

port-profile Access-I_ESX-VM-NET_MGT

  description: ## I_ESX-VM-NET_MGT ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Access-I_ESX-VM-NET_MGT

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 2014

  evaluated config attributes:

    switchport mode access

    switchport access vlan 2014

  assigned interfaces:

port-profile Access-I_ESX-VM-Net_PUB

  description: ## I_ESX-VM-Net_PUB ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Access-I_ESX-VM-Net_PUB

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 2001

  evaluated config attributes:

    switchport mode access

    switchport access vlan 2001

  assigned interfaces:

port-profile Access-I_WIN-NET_PRI

  description: ## I_WIN-NET_PRI ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

system vlans: none

  port-group: Access-I_WIN-NET_PRI

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 2100

  evaluated config attributes:

    switchport mode access

    switchport access vlan 2100

  assigned interfaces:

port-profile Access-Z_IKB_VSERV7-8

  description: ## VSERV7-8 bzw. public ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Access-Z_IKB_VSERV7-8

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 310

  evaluated config attributes:

    switchport mode access

    switchport access vlan 310

  assigned interfaces:

port-profile Access-Z_IKB_VSERV7-8neu

  description: ## VSERV7-8neu bzw. public ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Access-Z_IKB_VSERV7-8neu

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 311

  evaluated config attributes:

    switchport mode access

    switchport access vlan 311

  assigned interfaces:

port-profile InfraAccess-FT

  description: ## FT ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: InfraAccess-FT

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 902

  evaluated config attributes:

    switchport mode access

    switchport access vlan 902

  assigned interfaces:

port-profile InfraAccess-I_ESX-NET_MGT

  description: ## I_ESX-NET_MGT ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: InfraAccess-I_ESX-NET_MGT

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 2010

  evaluated config attributes:

    switchport mode access

    switchport access vlan 2010

  assigned interfaces:

port-profile InfraAccess-VMotion

  description: ## VMotion ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: InfraAccess-VMotion

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 903

  evaluated config attributes:

    switchport mode access

    switchport access vlan 903

  assigned interfaces:

port-profile InfraAccess-VSM-Control

  description: ## VSM-Control ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: InfraAccess-VSM-Control

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 901

  evaluated config attributes:

    switchport mode access

    switchport access vlan 901

  assigned interfaces:

port-profile InfraAccess-VSM-Packet

  description: ## VSM-Packet ##

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: InfraAccess-VSM-Packet

  max ports: 32

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 900

  evaluated config attributes:

    switchport mode access

    switchport access vlan 900

  assigned interfaces:

port-profile Unused_Or_Quarantine_Uplink

  description: Port-group created for Nexus1000V internal usage. Do not use.

  type: ethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Unused_Or_Quarantine_Uplink

  max ports: -

  inherit:

  config attributes:

    shutdown

  evaluated config attributes:

    shutdown

  assigned interfaces:

port-profile Unused_Or_Quarantine_Veth

  description: Port-group created for Nexus1000V internal usage. Do not use.

  type: vethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Unused_Or_Quarantine_Veth

  max ports: 32

  inherit:

  config attributes:

    shutdown

  evaluated config attributes:

    shutdown

  assigned interfaces:

port-profile Uplink-Customer

  description: ## Uplink zu DF-ESX-C-01 ##

  type: ethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Uplink-Customer

  max ports: -

  inherit:

  config attributes:

    switchport mode trunk

    switchport trunk allowed vlan 310-311,2001,2100

    no shutdown

  evaluated config attributes:

    switchport mode trunk

    switchport trunk allowed vlan 310-311,2001,2100

    no shutdown

  assigned interfaces:

port-profile Uplink-FT

  description: ## Uplink zu DF-ESX-B-01 FT ##

  type: ethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Uplink-FT

  max ports: -

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 902

    no shutdown

  evaluated config attributes:

    switchport mode access

    switchport access vlan 902

    no shutdown

  assigned interfaces:

port-profile Uplink-Management

  description: ## Uplink zu DF-ESX-B-01 Mgmt ##

  type: ethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  system vlans: 900-901,2010

  port-group: Uplink-Management

  max ports: -

  inherit:

  config attributes:

    switchport mode trunk

    switchport trunk allowed vlan 900-901,2010,2014

    no shutdown

  evaluated config attributes:

    switchport mode trunk

    switchport trunk allowed vlan 900-901,2010,2014

    no shutdown

  assigned interfaces:

port-profile Uplink-VMotion

  description: ## Uplink zu DF-ESX-B-01 VMotion ##

  type: ethernet

  status: enabled

  capability l3control: no

  pinning control-vlan: -

  pinning packet-vlan: -

  system vlans: none

  port-group: Uplink-VMotion

  max ports: -

  inherit:

  config attributes:

    switchport mode access

    switchport access vlan 903

    no shutdown

  evaluated config attributes:

    switchport mode access

    switchport access vlan 903

    no shutdown

  assigned interfaces:

vemcmd show version

VEM Version: 4.0.4.1.3.1.0-2.0.3

VSM Version: 4.0(4)SV1(3a)

System Version: VMware ESXi 4.1.0 Releasebuild-260247

sachthak Fri, 10/08/2010 - 16:59

Hi Jean,


Based on the port profile names, I am guessing that the VSM is on the VEM with InfraAccess-VSM-Control and InfraAccess-VSM-Packet as the control and packet port groups for the VSM VM. If so, the vlans on these port profiles 901/900 should be defined as system vlans as well.


Hope this helps


Thanks,

Sachin

jean.kobben Tue, 11/02/2010 - 06:24

Hi Sachin, sorry for responding so late.at the moment we have Standard VS.the VSM is connected to 3 Portgroups; Management, Control and PacketThe VLAN IDs of Packet and Control are corresponding the VLAN IDs of the VSM. Because no host is connected to the VSM, we can't use InfraAccess-VSM-Control and InfraAccess-VSM-Packet.We're still at the beginning :( RegardsJean

Last Update.

i configured the system vlans on the corresponding portgroups on the VSM.

No Connection :(

jean.kobben Tue, 11/09/2010 - 03:00

Hi Sachin,

after adding "channel-group auto mode on" to all Uplink Portgroups, the VEMs registred.

Regards

Jean

scottn@selco.org Thu, 07/21/2011 - 16:47

In case anyone else runs across this thread (as I did in troubeshooting a similar issue) I wanted to share what fixed it for me.  In my case, I had accidentally added the ESX Host to the wrong VSM.  I removed the host from the VSM and added it to the correct one, but it still seemed to be broken.  I followed all of the steps in this document:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_0/troubleshooting/configuration/guide/trouble_5modules.html#wp1192946

However, everything checked out according to the document.  As a last resort, I decided to remove the ESX Host from the vDS and uninstall the VEM using the command "vem-remove -d" at the ESX host.  I then added the host back to the correct vDS, and the issue was resolved!  I had removed and added the host back many, many times, so I am certain the uninstalling the VEM and having VUM reinstall it is what resolved the issue.  If the above Cisco document does not shed any light, uninstalling and reinstalling the VEM may be useful for you.

Actions

Login or Register to take actions

This Discussion

Posted February 5, 2010 at 5:11 AM
Stats:
Replies:13 Avg. Rating:
Views:12721 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard