×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SA 520 W Painfully slow

Unanswered Question

I recenly installed an SA 520 W for client using Verizon DSL (3 meg down). This box replaced an old Firebox firewall. Prior to the switch, download speeds were close to the advertised 3 meg. Now, with the SA 520 in place, we are receiving roughly 300kbps down with a massive ammount of latency. There have been no other changes introduced. This slowness is present even with all workstations powered off (there are 7). The firmware is up to date. Cisco support reccomends defaulting the box which I am reluctant to do as I beleive it to be a fools errand.


Any thoughts or suggestions?


Thanks!

Bob


Message was edited by: [email protected]

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hornstein Sat, 02/06/2010 - 21:19
User Badges:
  • Gold, 750 points or more

Hi Bfriend,


Doesn't make sense, the box is infinitely more powerful compared to something like the WRVS4400N.


YES , do what Small Business Support Center suggest , factory reset and try the throughput test from your PC to something likespeedtest



Report on how it's running from a copper Ethernet connection from the SA520W to the Speed test location near you.


regards Dave

Steven Smith Mon, 02/08/2010 - 09:20
User Badges:
  • Gold, 750 points or more

What firmware are you running?  Are you running PPPoE through the SA520?

Steven Smith Mon, 02/08/2010 - 09:45
User Badges:
  • Gold, 750 points or more

To both of you, are you running your own DNS servers or is the SA 520 running the DNS proxy?

Steven Smith Mon, 02/08/2010 - 09:56
User Badges:
  • Gold, 750 points or more

Turn on logging...

Administration -> Logging -> Logging Facility and Severity


Turn on Debugging level for System, Kernel, Network, and Firewall.


Can you get a sniffer from Administration -> Diagnostics -> Packet Trace, do this on the WAN interface.



Use that and recreate the issue with the web pages. 


Get the sniffer and the logs and post them here please.

Steven Smith Mon, 02/08/2010 - 12:26
User Badges:
  • Gold, 750 points or more

Could you go to Firewall -> Attacks and uncheck the box for block fragmented packets?

Steven Smith Thu, 02/11/2010 - 15:41
User Badges:
  • Gold, 750 points or more

Did this disable fragmented backs help?

Actions

This Discussion

Related Content