Cisco 1841 Config

Unanswered Question

Hello

I am new to this so please forgive my approach. I do have a Cisco router 1841 with os 12.4. I could not get the traffic on the LAN to access the ISP any help will be highly appreciated. Thanks

When pinging from 192.168.195.173 to LAN works fine

pinging from from LAN (172.40.10.x) to 192.168.195.174 works fine but not to the next node 192.168.195.173 ISP Side

LAN 172.40.10.0/24

Public IP  78.93.10.0 255.255.255.248

ISP gate 192.168.195.173

Bellow is the config file

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable password compr1
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip domain name company.net
ip name-server 212.93.192.4
ip name-server 212.93.192.5
!
!
!
!
interface FastEthernet0/0
ip address 78.93.10.233 255.255.255.248 secondary
ip address 172.40.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.195.174 255.255.255.252
duplex auto
speed auto
!
ip default-gateway 192.168.195.174
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.195.173
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password compr1
login
!
end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Sun, 02/07/2010 - 04:56

Hi,

Just configure ip route 0.0.0.0 0.0.0.0 ISP ip in router and remove ip default-gateway 192.168.195.174.

and what exactly is your requirement just to ping the isp end and vice versa. Having public ip in lan segment is also a question what is it for ?

HTH

Ganesh,H

Hi Ganesh

Thanks for your quick reply, Yes what I need to achieve is getting all nodes on the LAN network connects to the Internet VIA ISP provided Leased Line

My router connects to ISP via fa0/1 (192.168.195.174) >>>>> (192.168.195.173) ISP

You Suggest to add the ISP Network  by introducing ip route but I think that is already there as shown bellow, however I cannot browse internet from any pc on the LAN, Any Suggestions ? Thanks

ip route 0.0.0.0 0.0.0.0 192.168.195.173

Ganesh Hariharan Sun, 02/07/2010 - 05:41

Hi Ganesh

Thanks for your quick reply, Yes what I need to achieve is getting all nodes on the LAN network connects to the Internet VIA ISP provided Leased Line

My router connects to ISP via fa0/1 (192.168.195.174) >>>>> (192.168.195.173) ISP

You Suggest to add the ISP Network  by introducing ip route but I think that is already there as shown bellow, however I cannot browse internet from any pc on the LAN, Any Suggestions ? Thanks

ip route 0.0.0.0 0.0.0.0 192.168.195.173

Hi samir,

I know the default route was there but another commnad default gateway was laso ther just remove that command only one default route towards the ISP will be suffient.

For browsing from lan you need to configure NATTing in router check out the below link and configure a dynamic nat and then check.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080093f31.shtml

HTH

Ganesh.H

bapatsubodh Sun, 02/07/2010 - 09:17

Hi Sameer,

As Ganesh has correctly pointed out NAT or PAT  is not seen in the configuration which you have posted.

Secondly, do you have one pool of  static IP from ISP or you have two Pools ?

It is most likely that for WAN, ISP may give a small subnet of /30 and for your actual use ISP may give different pool.

| Your_LAN_Subnet |  ----> Router INSIDE interface -----> NAT / PAT  -------> WAN Link--------> ISP - cloud

LAN - is say fa0  ( treat this as "inside" interface )

WAN - serial 0 ( it may be fast 1 ) Treat this as "outside" interface

Step 1. Define your LAN network in access-list

access-list 101 permit ip LAN_Subnet WC_Mask   any

Step 2 : Define pool  of static IP that you will receive from ISP , you can define a single IP in the pool which will save your static IP and you will

be configuring PAT insted of NAT ( overloading )

ip nat pool ISP start-address end-address prefix 30

example:

ip nat pool ISP 10.10.1.1 10.10.1.1 prefix 30

Lastly you define inside and outside interfaces

EXample:

int fast0

ip nat inside ( makes this interface inside)

int serial 0

ip nat outside ( makes this interface outside )

use following NAT

ip nat inside source list  "Acces-list -name / number"  pool "Pool_name "  overload

overload keyword : is very important

You already have default route pointing to ISP side,  assuming you have not configured any access-lists , I think you are good to go.

for accessing internet.

Last but not least to check if your NAT is working or not try

debugging the NAT.

#debug ip nat

# show ip nat translations. ( this will give you exactly clear picture )

HTH, rate if helpful.

Thanks

Subodh

Actions

This Discussion

Related Content