ASA running EIGRP but not exchanging routes with cisco 4900-M

Unanswered Question
Feb 8th, 2010
User Badges:

Hello,

i have a situation where we have an ASA currently connected to a Cisco 3800 router

running EIGRP and everything works fine, i.e. eigrp neighbour is formed 

and routes exchanged.


I need to move the ASA from the 3800 to our new data centre and connect it to a Cisco 4900-M running EIGRP.


I reconfigured the ASA to the new IP addressing scheme (to match the 4900-M) and included the new network statement in EIGRP.


I cabled the ASA to the 4900-M. Interfaces came up and EIGRP neighbour was formed. However, no routes were exchanged between devices. From the 4900 i could ping the ASA interface withou any problems. I debugged EIGRP on the 4900 and did not see anything that would cause them to not exchange routes. I have another device (3800) on the same subnet and the 4900 is able to exchange routes with it as is the ASA. There are no filters applied to the 4900-M or the ASA.



Has anyone seen a similar issue or have any ideas what the problem, could be? I had to back out the change and as soon as i reconfigured the original IP address on the ASA and moved it back to the old network everything worked fine again.


Thanks,

Ray

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 02/08/2010 - 02:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ray,

verify what is the EIGRP router id on the ASA and on the C4900M.


if equal it prevents learning of external EIGRP routes injected by the other device.


if the problem affects also internal routes verify MTU on both devices, there can be a mismatch with the C4900M likely having an higher one.


use sh ip eigrp interface type x/y to verify all EIGRP parameters


Hope to help

Giuseppe

rays Mon, 02/08/2010 - 02:59
User Badges:

Hi Guiseppe, thanks for you're reply.


The 4900-M does not have a router id configured. Would this cause this problem? The MTU is default 1500. There are no routes exhanged at all between ASA and 4900, either internal or external.


Ray

Giuseppe Larosa Mon, 02/08/2010 - 08:02
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ray,

an EIGRP router.-id is chosen even if you don't configure it so this is not an issue.


Do they list each other in the list of neighbors?

sh ip eigrp neigh



if they don't see each other as neighbors there is some basic mismatch or in AS number, or in K parameters or in IP subnet.

Be aware that you cannot build neighborship using secondary ip addresses.


You should use debug commands to get feedback.


debug eigrp neigh

debug eigrp packet

debug ip eigrp notifications


see

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094613.shtml#nc



Hope to help

Giuseppe

rays Mon, 02/08/2010 - 08:12
User Badges:

Hi Guiseppe,


i stated previously that I do form an neighbour adjacency. Therefore my K values, MTU etc.. are correct (or else i would not have formed an adjacency).


I am not using secondary addresses. I debugged eigrp and did not see any indications that there was a problem.... very strange.


Thanks,

Ray

francisco_1 Mon, 02/08/2010 - 08:30
User Badges:
  • Gold, 750 points or more

I have seen similar issue before but only when network types does not match!


Can you post config..

ChandraBhanu Pa... Tue, 06/18/2013 - 12:10
User Badges:

I had same problem in ASA8.6, but resolved.


Kindly find the EIGRP specific configuration


Interface configuration


!

interface GigabitEthernet0/0

description Links to WAN Router

nameif OUTSIDE

security-level 50

ip address 10.1.1.4 255.255.255.192 standby 10.1.1.5

summary-address eigrp 100 10.1.0.0 255.255.0.0 1

!



Eigrp Protocol Confiuration




access-list eigrpACL_FR standard permit any



!

router eigrp 100

distribute-list eigrpACL_FR in interface OUTSIDE

neighbor 10.1.1.3 interface OUTSIDE

neighbor 10.1.1.2 interface OUTSIDE

network 10.1.1.0 255.255.255.192

redistribute connected

redistribute static

!




Regards,

Bhanu.


Note : If it resolves your issue flag it as resolved.

Actions

This Discussion