Caller Number will displayed without "0" or "00"

Unanswered Question
Feb 8th, 2010

Hello,

i have yust another Problem. When i was called, the Caller-Number ( the number who calls me ) will displayed without "0", so i cannot redial the Caller-Number when i was not on my place at this time.

I have these configured, but nothing happens; the Caller-Number is still without "0" on the Front.

>>

voice translation-rule 1
rule 1 /\(^.+\)/ /00\1/ type national national
rule 2 /\(^.+\)/ /000\1/ type international international
rule 3 /\(^.+\)/ /00\1/ type any subscriber

voice translation-profile ISDN_CALL_IN
translate calling 1

dial-peer voice 50 pots
description ** incoming dial peer **
translation-profile incoming ISDN_CALL_IN
incoming called-number .%
fax rate disable
direct-inward-dial
port 0/1/0
>>

With kind regards

    Hartmut

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Mon, 02/08/2010 - 09:59

You need to make sure of a few things...

Are you matching that dial peer on inbound calls?  Are you sure that you are getting the correct plan and type on inbound calls? 

ITK_SHF_1 Mon, 02/08/2010 - 10:15

Yes, i have some Rules to match the inbound Called Numbers.

>>

voice translation-rule 5
rule 1 /26764275/ /155/

voice translation-profile LK-OP_Called_5
translate called 5

dial-peer voice 3005 pots
description LK-OP
translation-profile incoming LK-OP_Called_5
incoming called-number 26764275
direct-inward-dial
port 0/1/1

.

.

.
>>

When i see the "Calls in absentia" i can not call them back, because the "0" for CallOut is not present.

regards

    Hartmut

Steven Smith Mon, 02/08/2010 - 10:58

A call will match 2 dial peers on a call.  The question is, what is the 2nd dial peer it is matching?

Are the calls coming in an ISDN (in your case, BRI)?  If not, it will never match because you will never see the type and plan fields matched.  If it is BRI, you might need a debug isdn q931 to see if the calls are actually coming in with the correct plan and type.

ITK_SHF_1 Mon, 02/08/2010 - 11:41

Sorry,

here the 2nd dial-peer:

dial-peer voice 51 pots
description ** incoming dial peer **
incoming called-number .%
fax rate disable
direct-inward-dial
port 0/1/1

regards

   Hartmut

Actions

This Discussion