Monitoring PRI using Embedded Event Manager

Unanswered Question
Feb 9th, 2010
User Badges:
Hi, 

I am trying to use Embedded Event Manager to flag  when calls on a pri get above
28 but its not working.  I found an OID which shows number of calls currently on
the B Channels of a pri.  I dropped the threshold to two just to check it was
functioning correctly.  Config below:

event manager applet bchan-mon
event snmp oid 1.3.6.1.4.1.9.10.19.1.1.11 get-type exact entry-op gt entry-val
2 poll-interval 60
action exceeded syslog priority critical msg "All Chanels in Use"


I have done a debug and it says the OID is not found even though if i do a show
snmp mib i see the OID.  Output below:

Feb  9 08:35:58.097: fh_process_async: re=445EF694, timer_type=POLL
Feb  9 08:35:58.097: snmp_entry_value_check: OID unavailable, value check
skipped
Feb  9 08:35:58.097: snmp_entry_value_check:Returning FALSE
Feb  9 08:35:58.097: fh_process_async: update_t=0cron_tick: num_matches 0


Has anyone successfullly used EEM to do this?

Any help appreciated.

Thanks

Kev
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 02/09/2010 - 09:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

First, this is not an object instance.  You need to add a .0 to the end of this OID.  Next, this object may not return what you want.  Have you tried performing an SNMP Walk or Get on this object to see if it works?  What version of IOS is your device running?  What kind of device?

kevinhobson2000 Wed, 02/10/2010 - 01:45
User Badges:

Hi Joe,


I get this from an snmp walk:



[email protected]_nnm_u > snmpwalk lr2196 1.3.6.1.4.1.9.10.19.1.1.11
cisco.ciscoExperiment.19.1.1.11.0 : Unsigned32: 0


The device is a cisco 2851 and the IOS is C2800NM-SPSERVICESK9-M 12.4(18e).


If i run a debug now after adding the 0 i dont get a OID error not found anymore but its still not flagging the message in the log when the amount of calls go above 2.  See below:


Feb 10 09:43:17.774: fh_process_async: re=463448F0, timer_type=POLL
Feb 10 09:43:17.774: snmp_value_uint_compare:op1=0 op2=2 ret=FALSE
Feb 10 09:43:17.774: snmp_entry_value_check:Returning FALSE
Feb 10 09:43:17.774: fh_process_async: update_t=0



Thanks


Kev

kevinhobson2000 Wed, 02/10/2010 - 04:13
User Badges:

Hi i got this working by using a different OID which is 1.3.6.1.4.1.9.10.19.1.1.4.0 .


Cheers


Kev

Actions

This Discussion