Inbound CAC on an h323 gateway

Unanswered Question
Feb 9th, 2010


I am trying to redirect an inbound call at the gateway level on an h323 gateway. The calls come in on a single PRI. What I am trying to do now is use two different inbound dial-peers with the same incoming called-number and the max-conn command. This works fine in the outbound direction however I cant seem to get the call to hunt to the next, lower preference dial-peer for inbound calls. Any ideas on how to get this to work? Thanks for looking!

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

dial-peer voice 112 pots

max-conn 1

incoming called-number 8165551212



dial-peer voice 113 pots


preference 1

max-conn 2

incoming called-number 8165551212


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
markbatts Tue, 02/09/2010 - 07:31

On first view i would expect this to work.Have you ran a debug voip dialpeer to see whats going




Tommer Catlin Tue, 02/09/2010 - 08:50

Id do a debug on the dial peer to see whats going on.

I assume when you tested this, you have one call pegged up and its using dial peer 112.  Then create a second call and then it should hit dial peer 113.

If it does not, the debug dial peer will show this.

nathanreynolds Tue, 02/09/2010 - 12:40

Thank you both for the reply. Yes we did busy out the first dial-peer.  We did look at the 'debug voip dialpeer' and we see these lines in particular:

Feb  9 14:13:14: %CALL_CONTROL-6-MAX_CONNECTIONS: Maximum number of connections reached for dial-peer 112

Feb  9 14:13:14: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8473
        Cause i = 0x80AF - Resource unavailable, unspecified

I guess I just assumed it would hunt to the next dial-peer at this point. Any ideas why its not? I have attached the full result of the debug in case you are interested. Thanks for the help! Nathan


This Discussion