Router with Ethernet Module Problems

Unanswered Question
Feb 9th, 2010
User Badges:

Hi,


I have a 2801 Router running 12.4(24)T2 with a 9 port Ethernet Module. The problem I have is that I have a phone and a PC connected to it. For some reason, the PC looses connection from time to time and I can't even ping it from the router. The router seems to be fine as well as the phone that by the way, never looses connection. I have checked that the phones have the PC port feature enable. Here is how the ports are configure:


interface FastEthernet0/1/0
switchport mode trunk
switchport voice vlan 80


As you can see the port is accessing vlan 80 which is our voice vlan but it doesn't show when I do sh vlan-switch:


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1/1, Fa0/1/2, Fa0/1/3, Fa0/1/5, Fa0/1/6, Fa0/1/7, Fa0/1/8
80  VLAN080                         active  


Has anyone experienced this problem before? Thanks in advanced.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Tue, 02/09/2010 - 07:57
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


Add portfast to your ports and see if you still loose connection


Switch(config-if)#switchport trunkencapsulation dot1q
Switch(config-if)#switchport trunk native vlan id
!--- This is the VLAN with untagged frames used by the PC.

Switch(config-if)#switchport mode trunk
!--- This enables trunking on the port for two VLANs, data and voice.
Switch(config-if)#switchport voice vlan id
Switch(config-if)#spanning-tree portfast trunk



HTH

Reza

Actions

This Discussion