Disk Wiped On Cisco ASA 5505

Unanswered Question
Feb 9th, 2010

Hello,

My Cisco ASA has suddenly lost all of its disk images although the disk is still intact.

Is there a preferred way to restore this to factory with the software back on it ?

Any help much appreciated.

Thanks.

S.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Tue, 02/09/2010 - 09:15

Hi Stephen

Do you have a TFTP server where the images are backed up ? If not, you might need to download a copy of IOS from CCO (only with some priviledges) and upload it to your ASA box from TFTP.. Please find the following URL to see the procedure to backup/restore IOS images:

https://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a008072142a.shtml

I hope you are able to access your device now, and on enable mode ? any reasons as to how you lost your IOS files ?

Thanks & Regards

Raj

stephenwilletts Tue, 02/09/2010 - 09:19

Hi,

I managed to get v8.2.2 to boot direct from the TFTP server but was unable to save the config.

Is there a command to save the config to disk0: ??

Also, will there be other files needed apart from the OS ?

I'm only able to boot to ROMMON.

Thanks.

S.

sachinraja Tue, 02/09/2010 - 09:50

Hi Stephen

You will have your ASDM images, secure desktop (if any) images on your disk 0 apart from the IOS... once you restore the IOS, you will be able to upload the ASDM and any other package file that you would need.. you can normally backup your configuration on disk 0 using

hostname# copy {startup-config | running-config} {flash:/ | disk0:/ | 
disk1:/}[path/]filename

but its always a good option to back it up on a network management system or an external tftps server for you to pull your configuration incase of crisis like this.. was the disk 0 not recognizable or were the content just erased? if so any idea how it was erased ? You do not have a copy of the config file now ? Is the ASA in failover mode ?

on rommon you can enable the following commands to boot the ASA..

rommon #0> add 192.168.1.1
rommon #1> server 192.168.1.2
rommon #2> file asa805-k8.bin
rommon #3> tftp

Check if this is working.. hope this helps.. all the best

Raj

stephenwilletts Tue, 02/09/2010 - 14:03

Hi Raj,

An IOS upgrade crashed on the unit and I had no choice but to wipe the disk.

I can boot the system from a tftp server but unsure of how to copy from tftp to the disk and enable this to boot.

Thanks for your help friend.

Regards,

S.

sachinraja Tue, 02/09/2010 - 14:10

Hi Stephen

"I can boot the system from a tftp server"  - Do you mean you have already done the rommon procedure to copy the IOS from TFTP to the device ? is the firewall now on enable mode ? incase you are in enable, you can just do a "copy tftp: flash:" to upload the image onto disk0:...does your ASA show an error something like this ?

ciscoasa# sh disk0:
Initializing disk0: cache, please wait...Failed.
No files on device

once you have your ciscoasa booted up, you can assign an ip address onto the inside interface, and place a laptop directly on the inside segment with tftp.. you can then copy the image from tftp to disk0..

Hope thsi helps.. all the best

Raj

stephenwilletts Thu, 02/11/2010 - 04:03

Hi Raj,

This is the latest.

I'm able to boot from the tftp image and get to the enable prompt.

When running the tftp: flash: command I'm getting a "not enough space on device" error.

I've named the interface and ip address set on the ASA OK and able to ping it.

This is the point that I got stuck before when trying to get the image from the tftp to the disk.

Look forward to hearing from you.

Stephen.

stephenwilletts Thu, 02/11/2010 - 04:12

Forgot to mention.

If I do a "sh disk" it shows that the following 4 files exist and that there is "0 bytes total (0 bytes free)".

coredumpinfo

coredumpinfo/coredump.cfg

crypto_archive

log.

Thanks.

S.

sachinraja Fri, 02/12/2010 - 14:34

Hi stephen

Sorry for the late response..

did you try formatting the flash to free up some space?  are the core dump files huge and taking that space ? just have the IOS on the disk and then try booting it ...

Raj

stephenwilletts Fri, 02/12/2010 - 14:52

Hi Raj,

I managed to format the flash and copy a v7.24 image and got it to boot ok.

However, this unit refuses to boot with a v8.x image, it just sits on the "loading..." prompt.

It has enough RAM and flash so not sure what's wrong with it.

Thanks.

Steve.

Scooterscs Fri, 04/30/2010 - 11:11

I am having a similar issue.  Everytime I load an image in version 7xx i get the error "Checksum verification on uncompressed image failed.".  I have tried ver 8xx and get "Loading...".  Any ideas?


sumval(0x89  ) chksum(0x0   )md5(0x6ef6dbb3 0xae4e08b2 0xb291546c 0x40b60f3a)
md5(0x15c4452a 0xbe3b19d1 0xbe7f3048 0x1ff83712)
Checksum verification on uncompressed image failed.

stephenwilletts Tue, 05/04/2010 - 02:35

Hi,

My particular problem was diagnosed as a faulty ASA unit and was replaced under warranty by Cisco.

v7.x worked fine but the problem only occured when using v8.x.

Hope this helps.

S.

Actions

This Discussion