SPA9000 gets MoH music from SIP Provider

Unanswered Question

Hi,

Since I changed my SIP provider, I have following problem :

When I get a call from a external SIP line and take them on hold,

the the caller will here the message on hold from my SIP provider and not my MoH configured in my SPA9000.


When I take an internal call on hold, the caller will hear my internal music.

It seems that the MoH message will be sent out to my SIP provider which overrides my MoH music.

How can I disable this in the SPA9000 to do not sent out this message ?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jestowe Tue, 02/09/2010 - 18:16

Thank you for visiting the Cisco Community.

What do you have for your PBX parameters for MoH?

Internal Music URL:

Internal Music Script:

Internal MOH Refresh Intvl:

Call Park MOH Server:

And on each extension of the phone, what is MOH Server set to?

Thanks,
Jeff.

jestowe Wed, 02/10/2010 - 11:58

Sir I have attached a previous post which seems to relate to your question.  It refers this issue to the ITSP.

https://www.myciscocommunity.com/message/6236#6236

Here is a link for setting up Music on Hold with the SPA9000:  (in case you wanted to verify it or anyone else wanted to know how to import their own file)

https://www.myciscocommunity.com/servlet/JiveServlet/download/14058-5524/lvs_moh.pdf;jsessionid=F9C1374564DA265CC1E393A665E63D03.node0

Thanks,
Jeff.

Dear Jeff,

Yes its seems that this customer has the same problem. But he got no fix for this problem.

It there a way to do NOT sent out INVITE message for MOH to tell ITSP it should take the call on hold ?

I can not understand why this problem is a problem at the ITSP as the action was done by the SPA9000 !?

How can I disable MoH in SPA9000 ?

This can be a problem to transferring external calls to internal extenions.

Thanks

Harry

Alberto Montilla Thu, 02/11/2010 - 10:18

Dear Sir;

Please try setting the [SIP] XFER Bridge Mode parameter to YES. This should make the trick. Please let me know the results.

Regards
Alberto

SimonJohnV Sat, 11/06/2010 - 23:58

Hi there Alberto,

I am new to the thread, however i am interested if you ever found a solution to the issue of music on hold with the SPA9000. I will explain my situation. I have a few clients i have setup with the SPA9000 and SPA942s. On two sites we have included the SPA3102 which allows for VoIP failure and also to have there exsisting PSTN (analog line) have a connection into the IP Telephone system.

When a call is recieved into the SPA3102 and directed into the SPA9000, and the calling party is put on hold by the receptionist, the music on hold from the SPA9000 works as expected. The calling party hears the "imusic".

When the call is received into the SPA9000 from the IPTSP (line 1) and the calling party is put on hold by the receptionist, the music on hold from the SPA9000 does not work.

In fact the calling party hears nothing. If the call is picked up and placed back on hold, then the calling party hears Music but this is not the "imusic" from the SPA9000, it is the music from the IPTSPs moh server.

What i have deduced up to now is that the IPTSP uses G729a codec and forces G711a or G729. (I am in Australia and they dont use G711u) They have requested that we adjust all the settings they can think of to force the SPA9000 to handle the MOH. i think this may be the issue, but i am not sure. As the IPTSP forces the codec to be G729a the SPA9000 doesnt handle the music on hold as requested as the codec the SPA9000 requires is G711.

Just a point on this if any calls are put on hold internally the whole system works as expected. The SPA9000 plays the "imusic" and all the SPA942s work as expected.

The configuration we have on the network is SPA9000 in bridged mode, the router has a DMZ to the SPA9000 so no ports are restricted.

Any assistance with this issue would be greatly appreciated.

Actions

This Discussion