Corporate/Local Directory not accessible on 7945 phones in CME

Unanswered Question

Hello all,


I have a CME system that has 2 7945 phones and 5 IP Communicators


on the 7945 phones the corporate/local directory does not show up, neither does the speed dials.  Only the missed,placed, recevied calls.

however on the IP communicators the directory is there as well as the speed dials.


has anyone run into this before?


I tried updating the firmware however that did not change anything,



thanks!


Ken

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
paolo bevilacqua Tue, 02/09/2010 - 12:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Check "show telephony-service" tftp-bindings to know the XML files related to the phones.

Then do "more xxxxx" and check if is has the services and directory in there.

paolo bevilacqua Tue, 02/09/2010 - 12:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

CME systems cannot be managed without remote access.


Customers nomrally request different things daily and is too inconvenient to travel on site every time.

here is the show telephony-service... i didn't see a TFTP Bindings on it



OptimaCME#show telephony-service

CONFIG (Version=7.1)

=====================

Version 7.1

Cisco Unified Communications Manager Express

For on-line documentation please see:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_series_home.html


ip source-address 192.168.130.253 port 2000

ip qos dscp:

ef (the MS 6 bits, 46, in ToS, 0xB8) for media

cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal

af41 (the MS 6 bits, 34, in ToS, 0x88) for video

default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup

load 7910 P00403020214

load 7960-7940 P00307020200

load 7945 term45.default

max-ephones 30

max-dn 60

max-conferences 8 gain -6

dspfarm units 1

dspfarm transcode sessions 10

dspfarm 1 MTP001

conference software

privacy  

no privacy-on-hold

hunt-group report delay 1 hours

hunt-group logout DND

max-redirect 10

voicemail 8000

cnf-file location: system:

cnf-file option: PER-PHONE

network-locale[0] US   (This is the default network locale for this box)

network-locale[1] US

network-locale[2] US

network-locale[3] US

network-locale[4] US

user-locale[0] US    (This is the default user locale for this box)

user-locale[1] US

user-locale[2] US

user-locale[3] US

user-locale[4] US

srst mode auto-provision is OFF

srst ephone template is 0

srst dn template is 0

srst dn line-mode single

moh music-on-hold.au

time-format 12

date-format mm-dd-yy

timezone 12 Eastern Standard/Daylight Time

call-park system application

no transfer-pattern is configured, transfer is restricted to local SCCP phones only.

keepalive 30 auxiliary 30

timeout interdigit 5

timeout busy 10

timeout ringing 180

timeout transfer-recall 0

timeout ringin-callerid 8

timeout night-service-bell 12

caller-id name-only: enable

system message Optima Services

web admin system name cmeadmin  password kn0wh0w

web admin customer name Customer

edit DN through Web:  enabled.

edit TIME through web:  enabled.

Log (table parameters):

     max-size: 150

     retain-timer: 15

create cnf-files version-stamp Jan 01 2002 00:00:00

transfer-system full-consult

transfer-digit-collect new-call

multicast moh 239.0.0.1 port 2000

auto assign 19 to 23

local directory service: enabled.

Extension-assigner tag-type ephone-tag.

paolo bevilacqua Tue, 02/09/2010 - 12:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

As mentioned above.

Do "show telephony-service tftp-bindings", then do "more xxxx" for the XML config files for the phones with the problem.

Here is the output from that command.  I don't see anything files for the 7945 phones like i see below with the 7960




OptimaCME#show telephony-service tftp-bindings

tftp-server system:/its/united_states/7960-tones.xml alias United_States/7960-tones.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7920-font.xml

tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7920-kate.xml

tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml

tftp-server system:/its/vrf1/MTP001.cnf.xml alias MTP001.cnf.xml

tftp-server system:/its/vrf1/SEP0016178CE38E.cnf.xml alias SEP0016178CE38E.cnf.xml

tftp-server system:/its/vrf1/SEP001A4B804BD0.cnf.xml alias SEP001A4B804BD0.cnf.xml

tftp-server system:/its/vrf1/SEP0013E81CE381.cnf.xml alias SEP0013E81CE381.cnf.xml

tftp-server system:/its/vrf1/SEP000854B274B2.cnf.xml alias SEP000854B274B2.cnf.xml

tftp-server system:/its/vrf1/SEP000000008000.cnf.xml alias SEP000000008000.cnf.xml

tftp-server system:/its/vrf1/SEP000000008001.cnf.xml alias SEP000000008001.cnf.xml

tftp-server system:/its/vrf1/SEP000000008002.cnf.xml alias SEP000000008002.cnf.xml

tftp-server system:/its/vrf1/SEP000000008003.cnf.xml alias SEP000000008003.cnf.xml

tftp-server system:/its/vrf1/SEP000000008004.cnf.xml alias SEP000000008004.cnf.xml

tftp-server system:/its/vrf1/SEP000000008005.cnf.xml alias SEP000000008005.cnf.xml

tftp-server system:/its/vrf1/SEP000000008006.cnf.xml alias SEP000000008006.cnf.xml

tftp-server system:/its/vrf1/SEP000000008007.cnf.xml alias SEP000000008007.cnf.xml

tftp-server system:/its/vrf1/SEP0021864FD408.cnf.xml alias SEP0021864FD408.cnf.xml

tftp-server system:/its/vrf1/SEP001E65912A0C.cnf.xml alias SEP001E65912A0C.cnf.xml

tftp-server system:/its/vrf1/SEP00247EDEB61B.cnf.xml alias SEP00247EDEB61B.cnf.xml

tftp-server system:/its/vrf1/SEP00161756FFF2.cnf.xml alias SEP00161756FFF2.cnf.xml

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf

tftp-server system:/its/vrf1/XMLDefault.cnf.xml alias XMLDefault.cnf.xml



OptimaCME#

paolo bevilacqua Tue, 02/09/2010 - 13:06
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Two of these files are for the 7945s, execute "more" on them.

paolo bevilacqua Tue, 02/09/2010 - 13:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes as mentioned in my first post.

You will be looking at URL for phone services and local directory.

paolo bevilacqua Tue, 02/09/2010 - 13:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Under the ephone, and configure type also.

Then do "create cnf-files" under telephony-service.

paolo bevilacqua Tue, 02/09/2010 - 13:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Seem like you have an incomplete and inaccuate installation, can't you get professional help ?

All the commands are self-explaining, or explained in the documentation really.

the commands you mentioned i have tried.


I appreciate your help on this however you have not said how to fix the problem.


I do not see a .xml file on the system for those 2 phones.


I tried using the create cnf-file command and resetting the phones.


everything works just fine for all the other phones just not these 2 7945's


any other commands i can try to get these phones to see the corporate directory?

dnicolaides Tue, 03/02/2010 - 03:53
User Badges:

Hi Ken,


This isn't regarding your root problem but rather a the error message you receive when trying to create CNF files.Every time I try create the CNF files I get the same error message. Apparently this is because NTP is not set although I have set the clock locally on the router. it seems the recommended way is to use NTP.



HTH


Dimitri

jeanvancaloen Mon, 03/01/2010 - 21:04
User Badges:

Hello,


I have no explanation nor is it treating (only) the root cause, but what I have found is that sometimes phones will "act out" (I had one extension not picking up and going straight to VM one out of 3 times it got called). Also fixed one other today with the exact problem you're describing: directories and services unavailable (like when before phones have been added to CME).  (BTW both were 7942Gs running CME/CUE on a C2921)


I tried a bunch of things on both occasions but ended up deleting the user/voicemail/extension/phone and recreating everything which fixed the problem. Frankly, looks like a bug to me...


Hope this helps


Cheers,

Jean.

paolo bevilacqua Tue, 03/02/2010 - 03:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Which exact IOS are you running ?

Mustapha Arakji Tue, 10/05/2010 - 03:28
User Badges:

Hi,


i'm facing the same problem but not on all my IP Phone, i have more that 100 Phone, and only 4 are facing this issue. (1 7911 and 3 7941).

Checking the tftp-bindings i don't see the .xml configuration file for some of the phones. The phones that have .xml config file found doesn't show the URL of the Corporate Direcotry !!!


I have tried the following vesions with no luck. (8.4.4 - 9.0.2SR2 - 9.0.3).

Also deleted cnf-files, and then created them again, still same issue.

I tried to remove the phone completely also from voice mail, still same issue.


Any ideas?

paolo bevilacqua Tue, 10/05/2010 - 03:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Check you have configured "type" under "ephone".

Actions

This Discussion

Related Content