Client is able to associate with 871w,but cannot grab an IP address

Unanswered Question
Feb 9th, 2010
User Badges:

Hi Pros,

             I been working on this projet,but I got for days on the samething. Wireless client is able to associate to the WAP,but cannot get an IP address from the vlan associate to the ssid. The routers displays the following message:SSID[dot11 SSID vpn-spare-test] : DISABLE, not associate with a configured vlan.There is the config, and of course some parts has been deleted from the config,


version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname VPN-spare-test
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$CK7J$6iuL6UJlAWBCuJI0pgdKx1
!
aaa new-model
!
!
!
!
aaa session-id common
!
!
dot11 ssid VPN-SPARE-TEST
vlan 1
max-associations 5
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 xxxxx
!
dot11 ssid dot11 ssid VPN-SPARE-TEST
!
ip source-route
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.xxx.1 192.168.xx.10
ip dhcp excluded-address 10.x.x.1 10.x.x.10
!
ip dhcp pool DHCPPOOL-VOICE
   network 10.x.x.0 255.255.255.0
   default-router 10.x.x.1
   !
ip dhcp pool DATA_POOL
   network 192.168.x.0 255.255.255.0
    default-router 192.168.x.1
  !
!
ip cef
!
password encryption aes
!
!
!
!
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport priority default 3
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 2
switchport voice vlan 2
switchport priority extend cos 5
spanning-tree portfast
!
interface FastEthernet4
ip address dhcp
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers tkip
!
broadcast-key vlan 1 change 10
!
!
ssid VPN-SPARE-TEST
!
ssid dot11 ssid VPN-SPARE-TEST
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
!
interface Dot11Radio0.2
encapsulation dot1Q 2
!
interface Vlan1
description DATA-VLAN
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan2
description VOICE-VLAN
ip address 10.x.x.1 255.255.255.0
!
interface BVI1
description DATA_BRIGING
ip address 192.168.x.1 255.255.255.0
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip


any insight will be accepted and thanks in advance,


Jean Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Tue, 02/09/2010 - 13:48
User Badges:
  • Red, 2250 points or more

Hi Jean


which port is the PC connecting on the switchports ? I see the radio interface configs might just not be consistent.. Please refer to this URL for configuration of your ISR router.. with DHCP and open authentication..


http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805e7a23.shtml#conf


Did you do a debug dhcp ? Is it showing any error ?


Raj

Jean Paul Enerst Tue, 02/09/2010 - 14:27
User Badges:

The issue is with the wireless hosts, they are unable to grab an IP, everything is fine for the wired host. debug dhcp does not show any output. Once again, the error states that the SSID is not associate to a vlan.


To answer your question, the wired host is on f0/2.


Thanks for your help,


Jean Paul

Jean Paul Enerst Tue, 02/09/2010 - 14:35
User Badges:

One more thing, I have 2 scopes. One for DATA and one for voice as we use VOIP. the wireless pool should be the same as the wired pool. Any host connected to port f0-f3 will grab an ip in the 192.168.x.x. Network, it is the same for the wireless host, they I need them to grab an IP in the 192.168.x.x. network as well.


This network 192.168.x.x is tied up to vlan 1, the default vlan. My question is, can I the wired and the wireless devices be in the same network? My common sense says YES, but at this point I start to have some boubt.


Thanks,


Jean Paul

Actions

This Discussion