How to get 3g card dial automatically on reboot

Unanswered Question


I have a Sprint 3g HWIC and as I understand it this card must be configured in a dialer group using DDR (Dial on demand routing).

So I set the dial idle-timeout to 0, but when I reload or reboot the router, it never dials or connects until I manually ping something on the Internet.

Is there a way to get this card up every time the router boots and keep it conected 24/7?


chat-script cdma "" "ATDT#777"  TIMEOUT 60 "CONNECT"

interface Cellular0/3/0
ip address negotiated
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cdma
dialer-group 1
async mode interactive
ppp chap password 7

ip route Cellular0/3/0
ip nat inside source list 1 interface Cellular0/3/0 overload
access-list 1 permit
access-list 1 remark Nat Access-List
access-list 101 deny   ip any
access-list 101 deny   ip any
access-list 101 deny   ip any
access-list 101 permit ip any
access-list 101 remark Traffic permited to cause Cellular0/3/0 to dial out.
dialer-list 1 protocol ip list 101

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

I have DDNS setup for the Cellular0/3/0 interface, but no packets are sent to update DDNS until the Cell is up with a newly assigned IP address that then needs updating via DDNS (catch 22).

NTP is also setup (per your suggestion) but this does not seem to make it go either as NTP updates are not initiated until the interface is up.

The "permanent" keyword is not allowed after dialer idle-timeout.

Now what do I do?


Paolo Bevilacqua Wed, 02/10/2010 - 10:12

You have to assign a LAN source for either NTP or DDNS. Otherwise, being the interface down they will not initiate as you noticed.

Sorry the permanenet keyword, is actally applicable to static route. that could help as well


This Discussion